[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Empty val-tags file

From: Fabian Cenedese
Subject: Empty val-tags file
Date: Mon, 16 Dec 2002 10:53:18 +0100


I've used now cvs for quite a while and never thought I'd run into such a
problem. But anyway here it is.

We tag our sources from time to time as it should be. But for some
reason not all tags go into the val-tags file. In some repositories it's
even empty. According to docu this shouldn't matter as cvs will refill it
next time a tag is used.
Problem is now that I get a "no such tag" error on some operations
if it is not in the val-tags file. And I don't know what to do to get it in.
Some operations work (log file, checkout module), some do not
(diff, checkout file). But those that work don't update the val-tags
file. If I manually add the tag in the val-tags file in the repo then also
the other commands work (with exactly the same settings as before).
But a different user had the same problems and adding the tag didn't
help in his case (assuming he did it right).

cvs log file:
symbolic names:
        Version16: 1.10
        VERSION15a: 1.9
        VERSION15: 1.7
        VERSION14: 1.7
        VERSION13: 1.5
        VERSION12: 1.4

cvs update -rVERSION15 file
cvs.exe [update aborted]: no such tag VERSION15

A cvs init didn't help either. Apart from this problem everything else
works (with the newest revision).

I use cvs 1.11.1p1 on Windows, repo is local or network, no difference.
I can't use 1.11.2 because of its problems on Windows and I haven't
tried a cvs version. There are no problems with access rights. I'm sorry
if this is a simple FAQ or newbie question or if it has been solved in
the cvs version, but I couldn't find more info.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]