info-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: vss2cvs.pl problem (Was: Cvs problem)


From: Jim McIntosh
Subject: Re: vss2cvs.pl problem (Was: Cvs problem)
Date: Thu, 11 Jul 2002 14:13:08 +0000

Hi Noel,
Yeah I'm on a windows machine (windows 2000 service pack 2) and I am using cygwin too. I have installed Activeperl 5.6 but I was previously using Cygwins perl.

I tried chomp before I tried to concatenate the two strings into $currfile but it didn't seem to work as the same error came up.

Thanks for your help,

James

>From: Noel Yap
>To: Jim McIntosh , address@hidden
>Subject: Re: vss2cvs.pl problem (Was: Cvs problem)
>Date: Thu, 11 Jul 2002 06:57:13 -0700 (PDT)
>
>--- Jim McIntosh wrote:
> > I'm having a problem with vss2cvs.pl the problem is
> > that when the
> > script tries to concatenate $currdir with $dirline
> > it seems to copy one over
> > the other rather than next to each other.
> > i.e
> > $currfile should be cvsrepository/hi.txt
> > however it ends up being hi.txtository
> >
> > Heres that part of the code:
> >
> > $currfile = "$currdir$dirline";
> > open(FILETYPE,"ss Filetype \"$currfile\"
> > $ssuserpass |");
> > $type = lc();
> > close(FILETYPE);
> >
> > Does anyone know how to fix this. Please help as I'm
> > only a student in 2nd
> > year at University and have never really used perl
> > or cvs.
>
>It looks like the initial (ie on the right-hand-side
>of the assignment) value of $currdir has a '\r' in it.
>
>My guess is that you're on a Windows machine. Is this
>correct?
>
>Are you using Cygwin? If so, are you using Cygwin's
>perl and are you using a binary-mounted directory?
>
>If all you want to do is get this script working, you
>can do a chop($currdir) before the assignment. I
>would think, though, that you'll run into other
>similar problems with the script and even line-ending
>problems later on with CVS if you are, in fact,
>running on a text-mounted directory.
>
>Noel


Join the worldÂ’s largest e-mail service with MSN Hotmail. Click Here

reply via email to

[Prev in Thread] Current Thread [Next in Thread]