[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS - import to 1.1

From: Matthew Persico
Subject: CVS - import to 1.1
Date: Mon, 11 Mar 2002 21:22:44 -0500

I am in the middle of getting a group of developers to convert to CVS. They
have all been raised on SCCS, PVCS, so I have to go slow with the whole
concept of sandboxing and lockless checkouts. So slowly, in fact, that they
are actually going to start out using cvs admin -l.  Sigh.

Anyway, I was trying to demonstrate today that CVS does allow locking and I
got bit by something I don't understand. I made a one file project with
nothing but a header of keywords.

I then imported this project, cd'd to a new dir, cvs checkout, cd'd into the
project dir and locked the file.

I then rlogin'ed as me, cvs checkout the project altered the file and
proceeded to commit it in spite of the lock.

After wiping the egg off my face and doing some furious typing at my own
desk, the nearest thing I can figure out to explain what happened is that
the lock was placed on and my commit as the other user was on 1.1 to
become 1.2. As soon as I had a 1.2 version to work with, all the locking
worked exactly as expected.

I always though that in the presence of a branch, a command w/o a -r option
worked on latest revision, main line code. I guess I need to re-read how
branches work.

In the meantime, since development is going to start on the mainline until
we all get more comfortable with CVS branches, I'd like to make avoid any
possibility of screw-ups by CVS newbies.

What I'd like to know is this:

Is there a way to cvs import into 1.1, not Without the branch, the
first lock and commit attempts will work as advertised.

If I cannot do this, then I have to create an empty project and then write a
script that will recurse a tree of code, doing cvs adds as appropriate and
I'd rather not do that.


Matthew Persico

reply via email to

[Prev in Thread] Current Thread [Next in Thread]