[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS pserver on RedHat 7.1 lets me login, but when I do import, it fa

From: Olav Lindkjølen
Subject: Re: CVS pserver on RedHat 7.1 lets me login, but when I do import, it fails
Date: Sun, 27 Jan 2002 02:10:03 +0100
User-agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010726 Netscape6/6.1

Something to do with cvs server running as root, inheriting the HOME environment variable. Create a user named "cvs" and run the server under that user. Or try this as root:

unset HOME
/etc/rc.d/init.d/inet restart

Regards from Olav!

Neil Aggarwal wrote:

I am trying to set-up a CVS pserver on my RedHat 7.1 development machine.
I tried reading the CVS book at, but it
does not cover xinetd, so I tried to adapt it myself.

Here is what I did as root:
cvs -d /usr/local/cvsroot init
/usr/sbin/useradd cvs
cd /usr/local/cvsroot
chgrp -R cvs .
chmod ug+rwx . CVSROOT

vi /etc/xinetd.d/cvs and added these lines:
service cvs
        port = 2401
        socket_type = stream
        protocol = tcp
        user = root
        group = cvs
        server = /usr/bin/cvs
        server_args = --allow-root=/usr/local/cvsroot pserver
        type = UNLISTED
        wait = no

Restarted xinetd:
/etc/init.d/xinetd restart

vi /usr/local/cvsroot/CVSROOT/passwd
Added my login and password copied from from /etc/shadow

I then tried to test it by going to a shell with my user account.

I typed:
cvs -d :pserver:address@hidden:/usr/local/cvsroot login
It asked me for my password and reported no errors, so I thought that
everything should be OK.

Next, I tried to import a new project, so I went to the
directory containing the project and typed:
cvs -d :pserver:address@hidden:/usr/local/cvsroot import -m "Test Project"
testProject neil start

I got these error messages:
cvs server: cannot open /root/.cvsignore: Permission denied
cvs server: cannot make path to /usr/local/cvsroot/testProject: Permission
cvs server: Importing /usr/local/cvsroot/testProject/src
cvs server: ERROR: cannot mkdir /usr/local/cvsroot/testProject/src -- not
added: No such file or directory

No conflicts created by this import

Any ideas why this is occurring?


Neil Aggarwal
JAMM Consulting, Inc.    (972) 612-6056,
Custom Internet Development    Websites, Ecommerce, Java, databases

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]