[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

merge issue

From: Schwenk, Jeanie
Subject: merge issue
Date: Thu, 24 Jan 2002 19:55:26 -0800

I received this from one of our engineers here (I added a few details for
clarity).  I think the merge behaved this way because of the order of the
tags.  Is that correct?
I tried several times to do the following:

cvs update -j systema_v1_2

Where the version in my current working directory and the systema_v1_2 (a
branch) version were both beautified (format).  This merge never worked,
with the conflict file saying that nearly the entire files were different.

So I tried something different.  I checked in my current, beautified
version, so that my version and the branch were both beautified and both
committed.  Then I did this:

cvs update -j HEAD -j systema_v1_2

The results of this were bizarre.  These files were merged.  Where there
were conflicts, the contents of systema_v1_2 were taken only.  No conflict
file was created.  ViewCVS's diff clearly showed the conflicts ... I know
they are there.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]