[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: CVS behind a firewall.

From: Gianni Mariani
Subject: RE: CVS behind a firewall.
Date: Sat, 13 Oct 2001 08:06:50 -0700

This is not a CVS question.  This is a firewall administration question.

You'll have better luck asking a networking group.

Having said that, as a guess you have a far too restrictive firewall.

If you do not have any services running on a particular port, firewalling
does not increase your security.  So what seems to be happening is that you
have firewalled all the ports so that NAT (Masquerading) does not work
anymore because the return packets have nowhere to go.

-----Original Message-----
From: address@hidden [mailto:address@hidden Behalf Of
Tarun Garg
Sent: Saturday, October 13, 2001 6:55 AM
To: address@hidden
Subject: CVS behind a firewall.

I am trying to access a cvs repository on the net ( lets say
from a linux machine.
The cvs client is version 1.10.8 ( bash is 2.04).

We use a proxy server ( SQUID) and a firewall ( ipchains).

now whenever I try to access a repository using pserver, I get a timeout.
The port number 2401 is open at our end.
We opened up all the ports once and tried to connect. I could connect at
that time. The client was using port number 1759 at our end. We opened up
that too.
Still it doesn't work.

I've tried repository access with via SSH. It works.

Does the cvs client randomly pick up ports at the client end ( in case of
Can I specify the port to be used at the client side ?
Or is there something wrong with our firewalling ( or proxy) software?
Is there something wrong with my understanding/expectation ?

any help/pointers would be appreciated.


Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]