[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Updating Main Trunk is Updating Branch

From: Garg, Sukh
Subject: Updating Main Trunk is Updating Branch
Date: Thu, 4 Oct 2001 12:03:29 -0400

This is not a reply to ur query rather i am posting u a query. Bcoz i
thought what u have done i need to achieve almost the same. So pls help me
File: browse.jsp       Status: Up-to-date

   Working revision:
   Repository revision: /cvs/NewJSP/src/products/browse.jsp,v
   Sticky Tag:          (none)
   Sticky Date:         (none)
   Sticky Options:      -kb

   Existing Tags:
        NewJSP-2001_10_01-Branch1   (branch:
        NewJSP-2001_10_01-Tag1     (revision:
        NewJSP_Rel_1               (revision:
        init                            (revision:
        start                           (branch: 1.1.1)

Above output is a result of "cvs status -v" command for my prj.

1. everything whatever i did, i did it from client WinNT.(CVS server is
-Tagging is done using rtag i.e "cvs rtag tagName moduleName"
-Branching is done using rtag i.e "cvs rtag -b -r tagName branchName
-module was tagged before branching.

Now questions :
1. Is my approach for Tagging & branching OK???
2. If it's Ok then why changes made on Main Trunk are visible on Branch as
well.Though i never merged main trunk with branch.

So pls suggest me what's wrong.


-----Original Message-----
From: Manoj Thakur [mailto:address@hidden
Sent: Wednesday, October 03, 2001 2:41 PM
To: address@hidden; address@hidden
Cc: 'Manoj S Thakur (E-mail)'
Subject: RE: Problem logging cvs on Windows

Hi Ruprecht,

You Wrote
> possible a portproblem on you windows box

Any ideas on how to figure out what the problem could be?

> that is normal I've read.
Yes - from what I read too, this is normal and I was expecting this to occur
on the Windows box, but it did not happen.

-- Manoj Thakur

-----Original Message-----
From: address@hidden [mailto:address@hidden
Sent: Wednesday, October 03, 2001 2:10 PM
To: address@hidden; Manoj Thakur; address@hidden
Cc: Manoj S Thakur (E-mail)
Subject: Re: Problem logging cvs on Windows

Am Mit, 03 Okt 2001 schrieb Manoj Thakur:
> Hello,
> I just installed WinCVS on my Windows 2000 machine and was getting errors
> while logging into the cvs server.
> So, I ran the cvs command (as shown below) in a windows command window.
> -----------------------------
> H:\test_cvs>cvs -d ":pserver:address@hidden:/vp/cvs_repository" login
> Logging in to :pserver:address@hidden:2401/vp/cvs_repository
> CVS password: *******
> cvs [login aborted]: unrecognized auth response from cvsserver: Unknown
> command: `'
> H:\test_cvs>cvs -version
> Concurrent Versions System (CVS) NT Beta 4 (Local Build 7)
>  (client/server)
> -----------------------------
> Then, I logged onto the linux cvs server machine (cvsserver) and
> ran the same command, this time it was successful (as shown below)
> -----------------------------
> cvsserver:mthakur 512$ cvs -d
> ':pserver:address@hidden:/vp/cvs_repository' login
> (Logging in to address@hidden)
> CVS password:
> cvsserver:mthakur 513$ cvs -version
> Concurrent Versions System (CVS) 1.11 (client/server)
> -----------------------------
> Any ideas??
> (The cvs service is installed on a Linux machine, std cvs port of 2401.
> If I run "telnet cvsserver 2401" on the windows machine, it immediately
> returns with the first line stating "Unknown command: `'" and then
> I get the 'cvs <anyInvalidOptionHere>' output.

possible a portproblem on you windows box

> >From the Linux box (or a SunOS box), the telnet command waits, till I hit
> 'Enter', when it gives the return value as "cvs [pserver aborted]: bad
> protocol start: ")
that is normal I've read.   Pserver seams to be difficult to set up.
I have problems in setting up too and think I'm turn around.


Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]