[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs repository in a bad state, and cvs seg faults on export

From: Stockinger, Frank
Subject: Re: cvs repository in a bad state, and cvs seg faults on export
Date: Fri, 4 May 2001 09:09:20 +0200


> We are having problems with one of our working areas. The developer told me
> Another symptom is that cvs will seg fault when I try to export this
> project. It progresses the export until it gets to the directory containing
> the files in question, at which point it seg faults. This happens if I run
> the cvs client on linux. If I run it on windows, it crashes in the same
> place with the message: 'Terminated with fatal signal 11'.
We do have a similar problem with cvs export in cvs 1.11. BTW, it does not occur
with cvs 1.10.8.
As I tracked down, the problem is in cvs checkout.c in the function 
For exporting the function isfile checks whether there is a CVS directory. But, 
if you use
pserver access a CVS directory will be temporaly generated. Therefore the 
export fails.
For our purpose I removed the isfile(CVSADM) check...
Maybe someone could check, whether this correct.

> We are using CVS 1.11 on Redhat Linux 7.0 for the repository.
Our environment is CVS 1.11 on SUSE 6.3 for the repository server.
> I'd appreciate any advice on how to restore the repository to a clean state
> from this locking problem.


plettac electronic security
Dr. Frank Stockinger
Würzburger Straße 150
90766 Fürth
Tel +49 (0)911 75884 334
fax +49 (0)911 75884 121
email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]