[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cannot export from remote repo to absolute pathname

From: John E. Hein
Subject: cannot export from remote repo to absolute pathname
Date: Wed, 25 Apr 2001 18:02:26 -0600

CVS 1.11

I am trying to export a subtree from a module at a remote repository
 to a local directory tree.  I tried:

cvs -d remotehost:/repo_dir export -d /local/dir some_module/sub/tree

I get:

cvs [export aborted]: absolute pathname `/local/dir' illegal for server

So, I tried a relative path:

( cd /local/dir ; cvs -d remotehost:/repo_dir export -d . some_module/sub/tree)

and got:

cvs [export aborted]: cannot export into working directory

So I tried to make a sym link:

ln -s /local/dir foo
cvs -d remotehost:/repo_dir export -d foo some_module/sub/tree

and got:

cvs export: cannot chdir to foo: No such file or directory
cvs export: ignoring module some_module/sub/tree

'cvs export' seems to be foiling all attempts to be able to export
 to an arbitrary local directory from a remote repository.

The following works, of course:

cd /tmp
cvs -d remotehost:/repo_dir export some_module/sub/tree
mv some_module/sub/tree /local/dir

But this extra step is time consuming, annoying and vulnerable to naming
 collisions in /tmp.  I could get around this by making a unique dirname
 in /tmp, but it shouldn't be that much work to do what I'm trying to do.

Is there a way to export from a remote repo to a directory specified
 with the -d switch to the export command?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]