info-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: why does wincvs show all files as modified


From: Drews, Sascha
Subject: AW: why does wincvs show all files as modified
Date: Tue, 17 Apr 2001 10:22:43 +0200

for anybody who wants to know

i solved the problem by replacing the cvs2ntslib.dll in the wincvs-dir with
the one from cvsnt. allthough my wincvs is showing a time-difference of 2
hours (nt-explorer 14:10h, wincvs 12:10h) the main-problem of
"checking-out-modificated" is terminated by this replacing...

bye

> -----Urspr√ľngliche Nachricht-----
> Von:  Drews, Sascha 
> Gesendet am:  Donnerstag, 12. April 2001 11:01
> An:   address@hidden
> Cc:   address@hidden
> Betreff:      AW: why does wincvs show all files as modified
> 
> hi chuck, hi anyone,
> 
> i think my problem is caused by different timestamps, but i don't know a
> solution by now.
> after reading your mail (chuck) i compared both the two computers. my
> cvs-server "lives" in timezone gmt+1 (germany...) and its actual time then
> was 09:25:00. my wincvs-client also is in gmt+1, time 09:25:43. but i
> thought this difference of 43 seconds couldn't be the problem.
> so i reinstalled server and client again, imported some java-files (in one
> directory) via wincvs-client, and checked them out with wincvs a few
> seconds
> later.
> the timestamps of the are these (date is in dd.mm.yy):
> -> original files - 30.03.01 10:14
> -> files in repository (after import) - 12.04.01 10:07
> -> files in client-working-dir (after checkout) - 12.04.01 10:07
> -> in wincvs all files are - 12.04.01 07:06:59 !!! (wincvs shows them as
> "mod. file")
> i think that's an internal problem of cvs or wincvs...
> i hope there's anyone to help me to workauround this problem.
> 
> 
> > -----Urspr√ľngliche Nachricht-----
> > Von:        address@hidden
> [SMTP:address@hidden
> > Gesendet am:        Mittwoch, 11. April 2001 18:44
> > An: address@hidden; Drews, Sascha
> > Cc: address@hidden
> > Betreff:    RE: why does wincvs show all files as modified
> > 
> > Sascha,
> > 
> > I'm having a similar problem, but I am under the impression that it is 
> > related to an incompatibility between cygwin's cvs.exe and WinCVS, the 
> > problem being related to the timestamps the these two application 
> > formulate. However, early on the the diagnosis of my problem, David 
> > (sorry, don't know your last name) sent me a patched WinCVS cvs.exe. 
> > Maybe it is applicable to the problem you are reporting. (You aren't 
> > using cygwin cvs.exe, are you?).
> > 
> > David,
> > 
> > Do you have any patches for the timestamp problem that are applicable 
> > to WinCVS users that aren't using cygwin cvs.exe?
> > 
> > Anyone,
> > 
> > Would anyone care to comment on the joint use of cygwin cvs.exe and 
> > WinCVS - whether it is advisable, what to watch out for, how to 
> > configure the two systems to make sure they are compatible, etc. On the 
> > one hand, I am tempted to advise against their joint use. There is this 
> > problem with false locally modified flags and at least a couple of 
> > problems related to linefeeds. On the other hand, I'm wondering if a 
> > proper solution to the problem is to point one's cygwin PATH to the 
> > WinCVS version of cvs.exe. Can anyone see a problem with this approach.
> > 
> > Chuck
> > 
> > > -----Original Message-----
> > > From: sascha.drews [mailto:address@hidden
> > > Sent: Wednesday, April 11, 2001 10:25 AM
> > > To: info-cvs
> > > Subject: why does wincvs show all files as modified
> > > 
> > > 
> > > hello everybody out there.
> > > 
> > > i have installed an cvs-server on nt (latest version of 
> > > cvsnt) and a client
> > > (also nt) using wincvs1.2. connecting is no problem, import 
> > > of a module
> > > (from the wincvs-client) also seems to cause no errors 
> > > (*****CVS exited
> > > normally with code 0*****). but when i checkout this module (no
> > > error-message from cvs, too) wincvs displays each file as 
> > > "mod. file" with
> > > an red icon. what am i doing wrong? there was similar problem 
> > > discussed in
> > > this mailinglist some days before, where the solution was to uninstall
> > > wincvs and delete all registry-entries belonging to wincvs. i 
> > > did this a
> > > couple of times (including reboot of the system), but no chance...
> > > 
> > > i hope, there's somebody to help me...
> > > 
> > > ----------------------------
> > > MfG
> > > Sascha Drews
> > > 
> > > Team ERIS
> > > Mercoline GmbH
> > > Tel. +49 (0)30 4393 - 3048
> > > Mail  address@hidden
> > > ----------------------------
> > > 
> > > 
> > > _______________________________________________
> > > Info-cvs mailing list
> > > address@hidden
> > > http://mail.gnu.org/mailman/listinfo/info-cvs
> > > 
> 
> _______________________________________________
> Info-cvs mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/info-cvs



reply via email to

[Prev in Thread] Current Thread [Next in Thread]