[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Remove CVS lock error

From: Howard Zhou
Subject: Re: Remove CVS lock error
Date: Sun, 15 Apr 2001 21:56:20 -0700

It's cvs 1.11 running on Linux and NetBSD build systems. The repository is
on a netapp server NFS shared.
What happens is that two build machines are running update builds with the
same account meister on two different machines. If two update processes
owned by the same user running in the same directory at the same time. Both
processes tried to create #cvs.lock directory. When one process is finished,
it removed the lock dir. Then the second process tried to remove the lock
dir but it's gone already.

Does this explanation make sense?

So the workaround would be to schedule builds for each machine at a
different time.

I would appreciate if you can confirm this is a right approach?

----- Original Message -----
From: "Larry Jones" <address@hidden>
To: "Howard Zhou" <address@hidden>
Cc: <address@hidden>
Sent: Saturday, April 14, 2001 12:26 PM
Subject: Re: Remove CVS lock error

> Howard Zhou writes:
> >
> > Can someone tell me what caused this remove lock dir error below? It
> > to go away if multiple attempts. What can I do to avoid this error?
> What version(s) of CVS?  What platform(s)?  Local repository or
> client/server?  Is the respository on some kind of shared file system
> (e.g., NFS or Samba)?
> If you want help, you have to provide details.
> -Larry Jones
> Hey Doc, for 10 bucks I'll make sure you see those kids in the
> waiting room again real soon! -- Calvin
> _______________________________________________
> Info-cvs mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]