[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS lock error-help needed

From: Paddy T
Subject: CVS lock error-help needed
Date: Thu, 12 Apr 2001 17:24:22 -0700 (PDT)

I am getting the following CVS lock error.

One developer tried CVS update and got the error 

"cvs update aborted fatal signal 11 sent
cvs locks may need cleaning up"

at the file

Then she tried the update several times before
informing me.
When I saw in that dir in the repository,there were
read lock files with that developer as the owner.
I tried to manually delete these files;but I was
unable to remove those files in any way.After I give
rm command,it comes back to the shell prompt without
any error msg and also not deleting the files.
Later we tried to update from her working directory in
order to reproduce the error.
Then we got the following error.
"move away fforward.bmp it is in the way
move away fback.bmp it is in the way
cvs server created a cvs-serv***** directories in /tmp
directory.Lock files may need cleaning up."
(similar error msg;not these exact words)
I removed the cvs-serv*** files;still I am not able to
remove the read lock files in the repository.
And still she is unable to do update.
1.All the file names in images directory had been
changed from upper to lower case;but why only these 2
files are giving that error?
2.How can I remove the lock files from the repository?
They are shown by ls -l below.
-rw-r--r--  1 ckand     mnidev       0 Apr 12 16:05
-rw-r--r--  1 ckand     mnidev       0 Apr 12 16:05
-rw-r--r--  1 ckand     mnidev       0 Apr 12 16:06
-rw-r--r--  1 ckand     mnidev       0 Apr 12 16:07
-rw-r--r--  1 ckand     mnidev       0 Apr 12 16:29

Pls advice what I can do??

Thanks a lot,
Paddy Thomas

Do You Yahoo!?
Get email at your own domain with Yahoo! Mail.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]