[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Latest core CVS source

From: Larry Jones
Subject: Re: Latest core CVS source
Date: Fri, 6 Apr 2001 14:20:53 -0400 (EDT)

Ross Smith writes:
> Right.  On a pristine ccvs, I ran ./configure.  Then I ran make and it 
> complains and wants to rerun ./configure (see Listing 1).  Go
> figure.

That's because when you check things out of CVS, the files' timestamps
are set to the current time rather than the time they were committed
(for good reason) so it looks to make like the generated files are
out-of-date with respect to their source files and so it tries to
regerate them.  It appears that the regeneration is not working
correctly for some reason.

> BTW, the same thing happens on another Debian 2.2r0 box as well, so it's not 
> the box being mis-configured.

No, I'm sure it's not; it's almost certainly some kind of automake

> Well, I've successfullly built apache, doxygen, graphviz, kerberos, lyx, 
> mod_perl, mod_ssl, mysql, php, ssl, ssh, tcl, tk, & wine on
> this box without any problems.  I've also built several packages (apache, 
> mysql, ssl, ssh, etc.) using 'apt-get --compile source'.
> Again, no problems.

I'm sure that's true; Derek found a number of problems with automake and
made a number of enhancements to get it to handle CVS.  For a while,
there was no publicly-available version of automake that handled CVS
correctly, just his private version.  He was working closely with the
automake maintainers, so I expect that that is no longer true, but I
wouldn't expect anything other than the very latest (perhaps even beta)
release would work right.  It's entirely possible that there's a missing
version check that's allowing an earlier version to run and screw things

> > Could you do a ``cvs diff -u'' on the source tree
> > and send the results to info-cvs so we can
> > figure out what's going wrong?
> At what point?
> After ./configure, 'cvs diff -u' reports no changes.
> After running make, which reruns aclocal, autoconf, (automake?) and 
> ./configure, I tried running 'cvs diff -u', but I get
> "connection reset by peer".

That indicates a (hopefully) temporary server problem -- please try it
again.  What I want to know is how the results of rerunning that stuff
is different from what's in the repository.

> > I strongly suspect that if you overwrite your
> > locally-generated copies of the files with the
> > copies from the repository it will build just fine.
> Huh?  I started with a pristine checkout.  So you want me to...
> $ cvs co ccvs
> $ ./configure
> $ cvs up
> $ make
> ?

No, just ./configure and make.  After make fails, run the diff as per
above and then do ``cvs up -C'' to overwrite the locally-modified files
with the files from the repository.  Then re-do the ./configure and
make.  At that point, make should just start compiling instead of
rerunning all the autoconf/automake stuff.

-Larry Jones

Geez, I gotta have a REASON for everything? -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]