[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Problem with CVS-1.11, W2K client, Linux server.

From: Matt Smith
Subject: RE: Problem with CVS-1.11, W2K client, Linux server.
Date: Wed, 28 Feb 2001 13:06:47 +1000

The init command initialises the repository.  You then need to create
modules within that repository, using the import command.  When you use
checkout, you check out modules, not the repository.  That's why CVSROOT
works - it is a module within your repository.

> -----Original Message-----
> From: Kerry Kurian [mailto:address@hidden
> Sent: Wednesday, 28 February 2001 11:12 AM
> To: address@hidden
> Subject: Problem with CVS-1.11, W2K client, Linux server.
> Hello all,
> Apologies in advance for what may turn out to be a stupid 
> question. I'm
> only familiar with the discussions on the list over the past 
> few months.
> I've done everything I can think of to try to get a W2K CVS client to
> work with a Linux CVS server. It almost works, but I have a specific
> problem: I can't checkout a repository after I've created it. I can
> checkout the CVSROOT directory, if I specify it. But, "checkout .",
> which works on my Linux machine, doesn't work on the W2K client. As a
> result, I can't add files or directories to the repository I 
> am able to
> create.
> I'm guessing that I'm doing something completely boneheaded 
> (some of you
> might say: "Yeah, you're using Windows"), because I can't find any
> reference to this problem anywhere.
> Thanks in advance for your help.
> Examples follow:
> I can init a repository:
> Win2K>  cvs -d :server:address@hidden:/home/user/repository init
> But, when I try to check out this new repository, here's what happens:
> Win2K>  cvs -t -d :server:address@hidden:/home/user/repository 
> checkout .
> cvs checkout: notice: main loop with
> CVSROOT=:server:address@hidden:/home/user/repository
> S-> so_module (., Updating, , )
> cvs checkout: cannot open CVS/Entries for reading: No such file or
> directory
> cvs [checkout aborted]: no repository
> I've tried with the '.' in quotes, in apostrophes, escaped, etc.
> As a check of my own sanity, I logged into linuxbox and tried to
> checkout there:
> linuxbox>   cvs -d /home/user/repository checkout .
> cvs checkout: Updating .
> cvs checkout: Updating CVSROOT
> U CVSROOT/commitinfo
> [snip]
> U CVSROOT/verifymsg
> It turns out that cvs checkout on the W2K client does work if 
> I specify
> a named directory. For example:
> W2K> cvs -d :server:address@hidden:/home/user/repository 
> checkout CVSROOT
> cvs server: Updating CVSROOT
> U CVSROOT/checkoutlist
> etc. etc. etc.
> What's the deal? Thanks again.
> -K
> _______________________________________________
> Info-cvs mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]