[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MVS multiroot-status-1 problem (hey, we're almost there f

From: Larry Jones
Subject: Re: MVS multiroot-status-1 problem (hey, we're almost there folks)
Date: Mon, 5 Feb 2001 14:57:54 -0500 (EST)

Wayne Johnson writes:
> Sorry, you're quite right, I had twiddled with the two until the diff
> came out 0. Here's a new set.

According to my expr those match, so I think you've got an expr bug of
some kind; are you using a system expr or GNU expr?

>  I also switched to dotest_internal_debug
> (still not working) and included the check.log.  Still not seeing it.

Your version of dotest_line_by_line isn't handling blank lines correctly
(this is fixed in the current sources, but after CVS 1.11); change it as

@@ -432,6 +430,9 @@
     if $EXPR "`sed -n ${line}p ${TESTDIR}/dotest.tmp`" : \
        "`sed -n ${line}p ${TESTDIR}/dotest.exp`" >/dev/null; then
+    elif test -z "`sed -n ${line}p ${TESTDIR}/dotest.tmp`" &&
+       test -z "`sed -n ${line}p ${TESTDIR}/dotest.exp`"; then
+      :
       echo "Line $line:" >> ${LOGFILE}
       echo "**** expected: " >>${LOGFILE}

You may well find that line-by-line works even though all-at-once
doesn't, expr bugs are like that.

-Larry Jones

That's the problem with nature.  Something's always stinging you
or oozing mucus on you. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]