[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Configuration woes

From: bpeikes
Subject: Configuration woes
Date: Wed, 24 Jan 2001 21:18:06 -0000
User-agent: eGroups-EW/0.82

I'm trying to get cvs working under linux, and the docs on the 
cvshome site don't say anything about how to set it it up properly.
I downloaded the rpm from and installed it(whatever that 
means). It's in /usr/bin and it runs. My quesion is, what is the 
proper way to install it as a server?

I've created a cvsowner account.
as root I run:
> adduser cvsowner
> passwd cvsowner  (set the password) 
> cvs -d /usr/local/cvsroot init
> chown -R cvsowner.cvsowner /usr/local/cvsroot

edit /etc/inetd.conf and add:
cvspserver stream tcp nowait cvsowner /usr/bin/cvs -f --allow-
root /usr/local/cvsroot pserver

and restart inetd;

what I would like to do now is:
1) create a password file in cvsroot
2) change the config to not use the /etc/password

So now I run this as root:

> cvs :pserver:address@hidden:/usr/local/cvsroot checkout CVSROOT

This works and creates a copy locally.
I now create a passwd file in the local dir and run

> cvs :pserver:address@hidden:/usr/local/cvsroot add 

and get
cvs add: in directory .:
cvs [add aborted]: there is no version here; do 'cvs checkout' first

What the hell does this mean? Of course there is no version, I want 
to add it.....

Is there a nice concise instructions for setting up CVS "Properly". 
The docs show how to use it, but not how it should be configured.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]