[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Removed a file, now cannot add it back...

From: Eric Sommerlade
Subject: Re: Removed a file, now cannot add it back...
Date: Tue, 23 Jan 2001 16:54:42 -0100

Hola chicas,

we had the same problem here. 
In our case, the RCS file of the file in question was not placed in the
Attic directory (as the error message correctly states), but the state
of the file is 'dead', anyway.
So, when trying to restore the file via adding or update -j r1 -j r2,
cvs complains about the still 'living' file, since the RCS file is not
in the Attic.

The only solution I know is moving the file back into the Attic.
Unfortunately you need
direct access to the server, then.

I still wonder how this can happen - I suspected a crazy developer (with
nfs access to the cvs tree, too) here, but now I read that this can
happen with client/server cvs (as on sourceforge), too.
is it a bug or a feature?



Ferdinando Ametrano wrote:
> >Several months ago we removed a file from the CVS tree, and now we are
> >trying to check a file with the same name back in again.

> >.... [omissis] ....

> Since I do not have access to the SourceForge CVS I had to ask SourceForge
> support for their help.
> They solved the problem, but I'm not sure how.
> That's all I know.
> Any additional info is welcome, since I run once again into the same
> problem, so I guess there must be something more (e.g. problem with
> lowercase/uppercase file name using WinCVS client and Unix CVS server)
> ciao -- Nando
> _______________________________________________
> Info-cvs mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]