[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Remove does not work - not a dash P issue

From: Stephen Rasku
Subject: Re: Remove does not work - not a dash P issue
Date: Mon, 15 Jan 2001 17:18:19 -0800 (PST)

Shane Fisher wrote:

>Hey all,
>I'm having a really frustrating time with one of my CVS modules.  I'm 
>to delete it and all of its contents (-R default, right?) from the 
>wherein it lives.  Imagine a directory structure like so:
>I run the following commands:
>$ cd top 
>$ rm -fr sub
>$ cvs remove -R sub
>And I get the following output:
>cvs server: Removing sub
>cvs [server aborted]: could not chdir to sub: No such file or 
>When I run an "ls" on $CVSROOT/top I see "sub", clear as day, just 
>there laughing at me, complete with all of its original contents!  So 
how in
>the *&^% do I get rid of this stupid module?!

You can only "cvs remove" files in cvs.  You can't remove directories. 
 All you can do is "cvs remove" the individual files in the 
directories and then "cvs co -P" so that you don't get the empty 

Stephen Rasku                   E-mail: address@hidden
Senior Software Engineer        Web:
TGI Technologies              

reply via email to

[Prev in Thread] Current Thread [Next in Thread]