[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Importing vendor update without 1.1.1 branch

From: Kenn Humborg
Subject: Importing vendor update without 1.1.1 branch
Date: Fri, 5 Jan 2001 01:48:32 +0000

Hopefully there's an easy way out of this one:

Starting with an empty CVS tree, we did

   cvs import -b 2.2.14 module vendor vendor-2-2

This created files with versions on the vendor 
branch 2.2.14.  (Good intentions, bad idea....)

We continued development, adding files and modifying a few
vendor files.  The added files started at version 1.1
and the modified vendor files started at version 2.3.

Now I'm trying to import an updated vendor tree, and I'm having

I started with

   cvs import module vendor vendor-2-4

New files in vendor-2-4 that were not in vendor-2-2 were added
at version and updated files were not added because branch
1.1.1 cannot be found.  Oops!  It tried to create a 1.1.1 vendor
branch.  So I rig up a script to get the names of these new files 
and use cvs admin -o 1.1.1: to clear everything out of this 1.1.1

Of course, I should have specified that the vendor branch is 2.2.14.
So I tried again:

   cvs import -b 2.2.14 module vendor vendor-2-4

This time, updated files are imported OK at version,
but new files are not added:

   cvs server: /cvsroot/proj/module/file,v: can't find branch point 2.2
   cvs server: ERROR: Check-in of /cvsroot/proj/module/file,v failed

Is this because 2.2.14 appeared "out of nowhere"?

Is there any hope for this tree?  Would I be better off re-creating it
from scratch (and living with the loss of history info)?

Are there tools that can extract all the diffs and comments at each
commit and "replay" them into a new tree to rebuild the history?

Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]