[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Removed a file, now cannot add it back...

From: Ferdinando Ametrano
Subject: Re: Removed a file, now cannot add it back...
Date: Mon, 18 Dec 2000 16:25:39 +0100

Several months ago we removed a file from the CVS tree, and now we are
trying to check a file with the same name back in again.
.... [omissis] ....
1040 percival:Keil |> cvs commit
cvs commit: Examining .
cvs commit: cannot add file `standalonegeneva.lnp' when RCS file
already exists
cvs [commit aborted]: correct above errors first!
I had the same error on a SourceForge repository with a file called Makefile and posted here a request for help. Christian Brechbuehler <address@hidden> answered my question with the following:
> Apparently "something" is known about Makefile and makefile.
> But not on the server.  Most likely in Entries.
> Just delete the two offending lines from
> E:\Projects\QuantLib\Linux\CVS\Entries.  After that, "cvs
> update -A" should run without complaint, and then you
> can cvs add the file.

Since I do not have access to the SourceForge CVS I had to ask SourceForge support for their help.
They solved the problem, but I'm not sure how.
That's all I know.

Any additional info is welcome, since I run once again into the same problem, so I guess there must be something more (e.g. problem with lowercase/uppercase file name using WinCVS client and Unix CVS server)

ciao -- Nando

reply via email to

[Prev in Thread] Current Thread [Next in Thread]