[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: odd pserver problem

From: Hanser, Kevin
Subject: RE: odd pserver problem
Date: Mon, 11 Dec 2000 14:33:13 -0500

Hmmm... I think I've found part of my problem.
I modified the config file to set
and I noticed that other users couldn't log in anymore ... clue #1.

So I was looking thru the actual /cvs/master/CVSROOT dir, and I noticed that
the passwd
file was not updated.  It was still the older(est?) version.'

I've been doing a 'checkout CVSROOT', and then editing the passwd file, and
then committing it back into the repository.  But it appears that doesn't
update the actual passwd file??  What is the proper way to edit the passwd
file in the CVSROOT dir to get it to update?



-----Original Message-----
From: Hanser, Kevin [mailto:address@hidden
Sent: Monday, December 11, 2000 1:57 PM
To: 'address@hidden'
Subject: odd pserver problem

I am experiencing an "odd" problem with a pserver install of CVS.  I have
cvs installed, and working just fine for all users except one.  All the
users are set up the same...  that's why I can't figure out why this _one_
person can't login.  I keep getting :

cvs login: authorization failed: server <myserver> rejected access to
/cvs/master for user truefreak

This is the only user that gets that error.  I have a passwd file set up,
and I've copied and pasted the passwords for the users from the /etc/shadow
file.  (using same passwords as system login...)
my /CVSROOT/passwd file looks something like this:


(I'm mapping each user to the cvsuser, who owns the /cvs/master directory
tree and everything in it)

each user logging in is also a member of the cvs group, which is the group
that owns the directory.

I only get this error with this one user.  I've tried deleting the user
account, and re-creating it even, and I still get the same error.  I've
created other users that work fine...
I'm kinda puzzled on this one.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]