[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with importing vendor sources

From: Derek R. Price
Subject: Re: problem with importing vendor sources
Date: Wed, 25 Oct 2000 12:19:05 -0400

I think what you did was something like this:

---your changes---
\                 \-pre_test6_import
  \-test5 \-test6

In a normal vendor import with conflicts, the jyesterday command would have
merged changes between test5 and test6 into your changes above.

The merge command you described sounds messy and I'm not even going to try to
analyze it fully, but I think you merged a diff between your trunk tip and
test6 into your trunk, meaning you kinda backed out your changes but probably
caused some sort of mis-mashed mess due to the differences between test5 and
test6 and your trunk.

You should be able to tag the trunk and back out the mess you made and redo
the merge command the import specified:

    cvs up -A
    cvs tag current_head
    cvs up -A -jcurrent_head -jpre_test6_import
    cvs ci

The next merge should be something like:

    cvs up -jv2_4_0_test5 -jv2_4_0_test6
    cvs ci

No warranties and all that jazz.


Derek Price                      CVS Solutions Architect ( )
mailto:address@hidden     OpenAvenue ( )
He always has.

                - Humphrey Bogart as Rick, _Casablanca_

ben bodley wrote:

> hello  all,
> i have browsed the web, and FAQ and also "Open Source Development with CVS"
> for help on an issue regarding the importing of vendor code into our source
> tree, to no avail..
> we modify the linux kernel, and keep a CVS repository of the current kernel
> we are working on (lately v2.4.0-test5).. we add and modify files in the
> kernel..
> today i tried to import test6 (with the intent of importing test7, 8, and 9
> in the future) while keeping all our local changes.. basically i:
>  - updated, and commited any late changes to the repos.
>  - ran 'cvs tag pre_test6_import' (someone said to do this in case of
> complete disaster which is what has happened)
>  - did a new vendor import of the test6 kernel, kindof like 'cvs import -I
> ! -m "import of linux kernel v2.4.0.test6" kernel_org v linux'
>  - this had a few problems, and said to merge with a -jyesterday like
> command.. what i did was:
>  - ran 'cvs co -j pre_test6_import -j v2_4_0_test6 linux'
>  - shit!!!! had all these messages saying it was scheduling removal of all
> the files i added to the kernel, here pure logic stepped in and i panic'd..
> ctrl-c later..
>  - i didn't stop here (i should of) i thought i could do it properly, and i
> tried this - 'cvs co -j v2_4_0_test5 -j v2_4_0_test6 linux'
>  - seemed to work, i fixed all the conflicts, and recommited..
>  - hmmmm.. maybe i fixed it i thought... nup... after checking the
> repository i found that yes, it merged the test6 changes, but ignored all
> my changes to any files modified in the test6 import..
> i now have a completely useless cvs repository.. hooray..
> okay, well basically my cvs is royally screwed, and all i have is a cvs tag
> to fix it with.. however i have being trying to decrypt man pages and being
> a complete cvs newbie have had most information fly over my head, so i cant
> even get rid of all the changes from the import, i can check out to a local
> directory based on the tag, but then how do i say that the tag is where
> HEAD should be??
> if anyone can help me here, they would be doing great honour to my sanity..
> cheers for any insights :),
> ben
> --
> /\\------------------------------------------------------------- -- -
> ben.bodley/
> _______________________________________________
> Info-cvs mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]