[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: CVS 1.11 export with BINARY files (problem)

From: Milliken, Scott
Subject: RE: CVS 1.11 export with BINARY files (problem)
Date: Tue, 24 Oct 2000 14:19:39 -0500

Solaris CVS 1.11

Solaris CVS 1.11 using both :pserver: and local
Windows WinCVS 1.1

After this last message I tried one previously unused method - local export
rather than pserver export.  Same results.

As another test, I downloaded the source for CVS 1.10.8 and installed that
on the server.  Once completed I ran another export and the same thing

After much head scratching, I re-installed CVS 1.11 on the server side and
tried another export, but this time for some reason I tried a different set
of arguments, which then worked in all of the above described scenarios...

PREVIOUS:  cvs export -f -D 20001024 hydra
NEW:  cvs export -f -D today hydra

I would have thought that specifying today's date would have given me the
latest from today, but that's not the case.  Apparently it gives me the
earliest version from the day specified, which happened to be some
previously corrupted files (since I didn't immediately realize that I needed
to specify the binary flag on import).

Moral of the story:  The -D flag wants a full DATE/TIME, not just the date.

Thanks for the help.


-----Original Message-----
From: address@hidden [mailto:address@hidden
Sent: Tuesday, October 24, 2000 1:55 PM
To: address@hidden
Cc: address@hidden; address@hidden
Subject: Re: CVS 1.11 export with BINARY files (problem)

Milliken, Scott writes:
>       I have attempted to export both with and without the -kb option to
> the export command.  I am not using a ~/.cvsrc configuration file, either.
> I have also used an alternate client - namely WinCVS 1.1 beta 16 and the
> version of CVS that comes with that package.  It, too, will checkout
> correctly but corrupt on export, leading me to believe that the server
> is the problem.  Any other ideas?

You say you used an "alternate" client -- does that mean that the
original problem was also client/server CVS?  If so, that's a critical
piece of information you neglected to provide -- what platform and CVS
version are you using for the client and server?  (You said Solaris and
CVS 1.11, but it's not clear whether that's the client, the server, or
both.)  What form of client/server are you using (:ext:, :pserver:,
etc.)?  Does the problem still occur if you run CVS on the server
machine with a local repository?

-Larry Jones

What a waste to be going to school on a morning like this. -- Calvin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]