[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: need help with broken cvs trigger

From: Donald Ball
Subject: Re: need help with broken cvs trigger
Date: Mon, 2 Oct 2000 12:50:23 -0400 (EDT)

On Mon, 2 Oct 2000, Paul Sander wrote:

> Are the nested sub-shells really desired?  I find that that particular
> construct does not work (though I admit I'm not a bash user).  What happens
> if you move that stuff into a separate shell script and invoke it from your
> loginfo file instead?

i don't think so, no, but that was the example that was cited in the
manual. it warned of locking problems if it wasn't invoked as
described. the shell script to which you refer is actually a setuid c
wrapper for a java program, but nonetheless - if i remove the weird syntax
and simply make the line read:

^wz /usr/local/cvs/bin/checkin wz >>$CVSROOT/CVSROOT/updatelog 2>&1

i get the same error message:

Checking in foo8.html;
/usr/local/cvs/virtual/,v  <--
new revision: 1.5; previous revision: 1.4
Mailing the commit message...
: Ambiguous redirect

if i run the command by hand on the cvs server, i have no trouble.

> Also, is there no chance that you've somehow changed the shell that
> executes your loginfo commands?

nope. same old bash - bash-1.14.7-16.

- donald

reply via email to

[Prev in Thread] Current Thread [Next in Thread]