[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: One-off error in piping data to Gnuplot: bug link is a dud

From: Ben Abbott
Subject: Re: One-off error in piping data to Gnuplot: bug link is a dud
Date: Sun, 27 Nov 2011 11:45:59 -0500

On Nov 27, 2011, at 3:27 AM, Puranjoy Bhattacharya wrote:

> From: Ben Abbott <address@hidden>
> To: Puranjoy Bhattacharya <address@hidden> 
> Cc: "address@hidden" <address@hidden> 
> Sent: Sunday, November 27, 2011 4:51 AM
> Subject: Re: One-off error in piping data to Gnuplot: bug link is a dud
>> On Nov 26, 2011, at 6:39 AM, Puranjoy Bhattacharya wrote:
>> > I have been facing the problem with a Windows7 installation of Octave. 
>> > However, the bug report link that is quoted everywhere (quoted below) is 
>> > dead. Please send me the bugfix. I have faced this problem once before, 
>> > and remember having used a fix in form of building or installing some 
>> > package from Octave command line.
>> > 
>> > "When plotting Octave occasionally gives me errors like `gnuplot> 9 
>> > 0.735604 line 26317: invalid command'.
>> > There is a known bug in gnuplot 4.2 that can cause an off by one error 
>> > while piping data to gnuplot. The relevant gnuplot bug report can be found 
>> > at 
>> >";
>> The bug report you are referring to is with gnuplot.
>> The mail list you've sent your inquiry to is for octave.
>> I recommend you update you gnuplot to a more recent version.
>> I'm not a Windows user, so I can't help with that, but for someone to help 
>> you, you'll need to tell us where you got your copy of Octave from.
>> Ben
> Thanks for the prompt reply. The problem concerns piping data to GnuPlot from 
> Octave on Windows7. This GnuPlot in question is bundled with the Windows 
> installer of Octave downloaded from There's no other 
> GnuPlot installed on the system. I guess this refers to an issue that's 
> probably been solved for Linux, but persists on Windows. The quoted comment 
> is from the Octave FAQ.
> The problem that I'm facing is that when I use plot or imagesc from Octave, I 
> end up getting a one-off error. E.g. first plot command produces no graph, 
> second plot command produces the first graph, third produces the second, and 
> so on.
> With regards,
> Puranjoy

Please "reply-all". That way those more knowledgeable can comment as well. In 
addition, by replying at the bottom of the email it is easier for those who 
arrive late to follow along.

It is possible the problem you are seeing still exists for the developers 
sources. So I'd like to help fix this. If the problem has already be solved in 
the developers sources, there is a reasonable chance you'll be able to apply 
the same fix to your version.

Unfortunately, I don't have access to a Win7 machine. Until that changes, I 
won't be much help in debugging this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]