[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Help-gsl] Building gsl-1.15 under MinGW

From: Armin Armbruster
Subject: Re: [Help-gsl] Building gsl-1.15 under MinGW
Date: Wed, 17 Aug 2011 14:02:12 -0400

Hi Rob,

Thanks for your reply.

here's gcc -v:

$ gcc -v
Using built-in specs.
Target: mingw32
Configured with: ../gcc-4.5.2/configure 
--enable-languages=c,c++,ada,fortran,objc,obj-c++ --disable-sjlj-exceptions --wi
th-dwarf2 --enable-shared --enable-libgomp --disable-win32-registry 
--enable-libstdcxx-debug --enable-version-specific-r
untime-libs --disable-werror --build=mingw32 --prefix=/mingw
Thread model: win32
gcc version 4.5.2 (GCC)

Some more background:
- I'm using the latest MinGW (downloaded from,
- $ help ==>GNU bash, version 3.1.17(1)-release (i686-pc-msys)
- my host OS is MS Windows XP, SP3
- gsl downloaded from

Last night I've tried to build the same gsl on my computer at home (running 
Windows 7 Home Premium, SP1, 64 bit OS). I used the same MinGW installer and 
the same GSL package and make ran without problems.

I compared the config.log files in both cases (see attachment 
config_log_diff.txt). The only significant difference that I can see is that 
uname -s returns MINGW32_NT-5.1 on the XP machine and MINGW32_NT-6.1 on the 
Win7 machine.

The one thing I noticed is, that the resulting config.h is a direct copy of!!! The only difference is the first line added to config.h. That 
makes me believe that something with awk and/or sed isn't working properly. I 
don't have a full understanding of the configure script but from what I 
understand it is taking the file as a template and mangles it based 
on some test results to turn on some of the defines. Is that right?
According to the config.log file some of the HAVE_xxx switches should be turned 
on, for example at the very bottom of the config.log file in the confdefs.h 
section I see
but in config.h the corresponding line is the original

I attached the config.log and config.h file.
Does anybody have an idea what is going on?
By the way, I tried an older version of MinGW (installer 
mingw-get-inst-20100831.exe) with the same result.

Meanwhile I've followed John C.'s advice and installed the binary for gsl-1.13. 
Still, I wouldn't mind finding out what's going on, so thanks in advance for 
any help.


>>> On 8/17/2011 at 12:23 AM, "Sisyphus" <address@hidden> wrote:

> ----- Original Message ----- 
> From: "Armin Armbruster" <address@hidden>
> To: <address@hidden>
> Sent: Wednesday, August 17, 2011 6:57 AM
> Subject: [Help-gsl] Building gsl-1.15 under MinGW
>> Hi all,
>> I'm trying to build gsl-1.15 under MinGW and are having some problems.
>> I was following the instructions from INSTALL.
>> After running ./configure and make the compiler stops at infnan.c with the 
>> following error message:
>> infnan.c:98:3: error: #error "cannot define gsl_finite without 
>> infnan.c:115:3: error: #error "cannot define gsl_isnan without 
> ========================================
> Rather strange. When I build with MinGW (gcc-3.4.5) in my msys shell, 
> there's no problem.
> A diff on our configure outputs is attached (the '-' is what the OP had, the 
> '+' is what I had). Perhaps that rings a bell for someone here .... doesn't 
> ring any bells for me, but :-)
> Perhaps of more siginificance is the contents of (the generated) 
> gsl-1.15/config.h. You should be able to find the following line in that 
> file:
> #define HAVE_DECL_FINITE 1
> And you should also be able to find this line:
> Does your gsl-1.15/config.h contain those lines ? (Your configure output 
> suggests that you should at least have the first.)
> What does 'gcc -v' output for you ?
> Cheers,
> Rob

Attachment: config_log_diff.txt
Description: Text document

Attachment: config.h
Description: Text document

Attachment: config.log
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]