guix-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 2/2] gnu: Add python-lzo.


From: ng0
Subject: Re: [PATCH 2/2] gnu: Add python-lzo.
Date: Sun, 5 Feb 2017 11:37:40 +0000

On 17-02-05 01:31:18, Maxim Cournoyer wrote:
> Hi ng0,
> 
> address@hidden writes:
> 
> > From: ng0 <address@hidden>
> >
> > * gnu/packages/compression.scm (python-lzo): New variable.
> >
> > Co-authored-by: Danny Milosavljevic <address@hidden>
> > ---
> >  gnu/packages/compression.scm | 36 ++++++++++++++++++++++++++++++++++++
> >  1 file changed, 36 insertions(+)
> >
> > diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
> > index 64518fb6b..2545c4517 100644
> > --- a/gnu/packages/compression.scm
> > +++ b/gnu/packages/compression.scm
> > @@ -365,6 +365,42 @@ LZO is written in ANSI C.  Both the source code and 
> > the compressed data
> >  format are designed to be portable across platforms.")
> >      (license license:gpl2+)))
> >  
> > +(define-public python-lzo
> > +  (package
> > +    (name "python-lzo")
> > +    (version "1.11")
> > +    (source
> > +     (origin
> > +       (method url-fetch)
> > +       (uri (pypi-uri "python-lzo" version))
> > +       (sha256
> > +        (base32
> > +         "11p3ifg14p086byhhin6azx5svlkg8dzw2b5abixik97xd6fm81q"))))
> > +    (build-system python-build-system)
> > +    (arguments
> > +     `(#:test-target "check"
> > +       #:phases
> > +       (modify-phases %standard-phases
> > +         (add-after 'unpack 'patch-setuppy
> > +           (lambda _
> > +             (substitute* "setup.py"
> > +               (("include_dirs.append.*")
> > +                (string-append "include_dirs.append(\""
> > +                               (assoc-ref %build-inputs "lzo") 
> > "/include/lzo" "\")
> > +"))))))))
> 
> A bit hard to read/long line here. Maybe the various string components
> being appended could be aligned below the string-append call? Also, you
> could use single quotes for the Python code which might help to
> differentiate what is what.

It is already applied. I think "it's hard to read" is more than just a
cosmetic fix, so if you have an idea how to make this more readable,
feel free to send a patch.

> Is the guix linter happy?
> 
> > +    (inputs
> > +     `(("lzo" ,lzo)))
> > +    (home-page "https://github.com/jd-boyd/python-lzo";)
> > +    (synopsis "Python bindings for the LZO data compression library")
> > +    (description
> > +     "Python-LZO provides Python bindings for LZO, i.e. you can access
> > +the LZO library from your Python scripts thereby compressing ordinary
> > +Python strings.")
> > +    (license license:gpl2+)))
> > +
> > +(define-public python2-lzo
> > +  (package-with-python2 python-lzo))
> > +
> >  (define-public lzop
> >    (package
> >      (name "lzop")
> 
> Otherwise these 2 patches LGTM!
> 
> Maxim



-- 
ng0 -- https://www.inventati.org/patternsinthechaos/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]