[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnokii and Nokie N95 8GB

From: Arnold Troeger
Subject: Re: gnokii and Nokie N95 8GB
Date: Tue, 06 May 2008 21:54:37 +0700
User-agent: Thunderbird (X11/20080305)

I thought I'd summarize this thread to sort out my own understanding of the current status of gnokii, gnapplet, and the N95 8GB.

Gnokii was written to use the FBUS and AT protocols. The current generation of Nokia phones, the N series phones all(?) use Symbion OS which has no support for FBUS and limited AT command support. Gnapplet was written to address this change.

The N95 8GB runs Symbion OS 9.2, S60 rel 3.1. Gnapplet was written for Symbion S60, and the current version (0.6.2[45]) was written for S60 rel 2.x. Current attempts to port gnapplet to S60 rel 3.x have not been successful. Among other things S60 rel 3 requires applications to be digitally signed, but this is not the only issue.

The current versions of gnokii and gnapplet work somewhat with S60 version 3. However, you must debrand and jailbreak the phone (links are here:

Thank you Andraz!)
I'm not comfortable doing the above to my phone considering that the functions I'm interested in (phone book & sms) don't work well on S60 rel 3 with the current version of gnapplet.

Borbely Zoltan, the original author of gnapplet, is planning to buy an S60 3rd edition phone in the near future (soon I hope :-) and this may get us to a gnapplet running on S60 rel 3.

How can I help? I reasonably confident I could help with the testing. I've had a look at the GnuPoc website, but I don't see anything about S60 Rel 3, and I'm forbidden from the GnuPoc wiki. I'll keep looking for developer information, but any shortcuts will be greatly appreciated :-)

Thank you and very best regards,

Arnold Troeger                          
Email:  address@hidden          

reply via email to

[Prev in Thread] Current Thread [Next in Thread]