[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnewsense-dev] Fwd: Bugtrace of Yeeloong + on Debian Squeeze

From: ZHANG, Le
Subject: Re: [Gnewsense-dev] Fwd: Bugtrace of Yeeloong + on Debian Squeeze
Date: Tue, 14 Dec 2010 23:33:53 +0800
User-agent: Mutt/1.5.21 (2010-09-15)

On 10:17 Tue 14 Dec     , Cristian Paul Peñaranda Rojas wrote:
> On Tue, Dec 14, 2010 at 07:32:36PM +0800, wu zhangjin wrote:
> > This has already been fixed(or at least we can say there was already a
> > fixup), but the patch is not in the upstream Xorg yet, please refer to
> >
> I applied:
>   cat ../xf86-video-siliconmotion-1.7.3-fix-loongson.patch | patch -p1

This one is for video playback acceleration.
It has hard coded loongson specific SMID instructions.
You need to use a recent binutils and gcc which support -march=loongson2f to
compile it.
However, Debian defaults to mips1. That's why you got the error.

If your problem is X doesn't work at all. 
You need this patch: 999_loongson-mips-sarea-EnableIOPrts.diff.gz
This patch applies to xorg server, instead of siliconmotion driver.

> Inside sources for xserver-xorg-video-siliconmotion-1.7.3 (debian
> squeeze), but got this error

0260 C902 B8F8 6506 6586 2B90 BC51 C808 1E4E 2973

Attachment: pgpFWmPjp_Lfd.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]