gnash-commit
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnash-commit] /srv/bzr/gnash/trunk r10541: Numerous AS fixes for 26


From: Bastiaan Jacques
Subject: Re: [Gnash-commit] /srv/bzr/gnash/trunk r10541: Numerous AS fixes for 26 new swfdec testsuite and some actionscript.all
Date: Wed, 14 Jan 2009 05:06:35 -0800 (PST)
User-agent: Alpine 2.00 (DEB 1167 2008-08-23)

Global.cpp:

+        catch (boost::bad_lexical_cast&)

Does this compile for you without including boost/lexical_cast.hpp? It
doesn't for me.

Bastiaan

On Tue, 13 Jan 2009, Benjamin Wolsey wrote:

------------------------------------------------------------
revno: 10541
committer: Benjamin Wolsey <address@hidden>
branch nick: trunk
timestamp: Tue 2009-01-13 14:35:10 +0100
message:
 Numerous AS fixes for 26 new swfdec testsuite and some actionscript.all
 passes.
modified:
 libcore/MovieClip.cpp
 libcore/MovieClip.h
 libcore/as_environment.cpp
 libcore/as_function.cpp
 libcore/as_object.cpp
 libcore/as_value.cpp
 libcore/as_value.h
 libcore/asobj/Array_as.cpp
 libcore/asobj/Date_as.cpp
 libcore/asobj/Error_as.cpp
 libcore/asobj/Global.cpp
 libcore/asobj/LoadVars_as.cpp
 libcore/asobj/LoadVars_as.h
 libcore/asobj/LoadableObject.cpp
 libcore/asobj/NetStream_as.cpp
 libcore/asobj/Number_as.cpp
 libcore/asobj/Object.cpp
 libcore/asobj/String_as.cpp
 libcore/movie_root.cpp
 libcore/vm/ASHandlers.cpp
 testsuite/actionscript.all/Date.as
 testsuite/actionscript.all/Error.as
 testsuite/actionscript.all/Number.as
 testsuite/swfdec/PASSING
 testsuite/swfdec/swfdec_gnash_tester
   ------------------------------------------------------------
   revno: 10538.1.1
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 13:29:31 +0100
   message:
     Add a couple more tests in Number.as (all passing).
   modified:
     libcore/vm/ASHandlers.cpp
     testsuite/actionscript.all/Number.as
   ------------------------------------------------------------
   revno: 10538.1.2
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 16:14:35 +0100
   message:
     Move number conversion into separate functions so it can be used for
     parseInt too.
   modified:
     libcore/as_value.cpp
     libcore/as_value.h
   ------------------------------------------------------------
   revno: 10538.1.3
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 19:26:07 +0100
   message:
     Start using as_value::parseInt for Global.parseInt.
   modified:
     libcore/as_value.cpp
     libcore/as_value.h
     libcore/asobj/Global.cpp
   ------------------------------------------------------------
   revno: 10538.1.4
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 20:54:58 +0100
   message:
     Cleaned up but slightly unsafe version of parseInt.
   modified:
     libcore/asobj/Global.cpp
   ------------------------------------------------------------
   revno: 10538.1.5
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 21:19:13 +0100
   message:
     Clean it up and make safe.
   modified:
     libcore/asobj/Global.cpp
   ------------------------------------------------------------
   revno: 10538.1.6
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 21:29:06 +0100
   message:
     Use string size_type properly.
   modified:
     libcore/asobj/Global.cpp
   ------------------------------------------------------------
   revno: 10538.1.7
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Sat 2009-01-10 21:51:43 +0100
   message:
     More sensible name.
   modified:
     libcore/as_value.cpp
     libcore/as_value.h
     libcore/asobj/Global.cpp
   ------------------------------------------------------------
   revno: 10538.1.8
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 10:50:04 +0100
   message:
     Do doubleToString better in as_value. Move dox to header.

     Check Date.setTime() arguments better, so that swfdec test passes.
   modified:
     libcore/as_value.cpp
     libcore/as_value.h
     libcore/asobj/Date_as.cpp
     libcore/asobj/Number_as.cpp
   ------------------------------------------------------------
   revno: 10538.1.9
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 13:03:12 +0100
   message:
     Make leap years calculation more readable and do what it's supposed to.

     Handle setYear arguments properly.

     Passes in actionscript.all, and 8 more swfdec passes.
   modified:
     libcore/asobj/Date_as.cpp
     testsuite/actionscript.all/Date.as
     testsuite/swfdec/PASSING
   ------------------------------------------------------------
   revno: 10538.1.10
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 14:51:00 +0100
   message:
     Prefer valueOf over toString for all objects when comparing as_values where
     this is an object. Fixes ActionNewEquals for dates in SWF6+, and some
     swfdec testcases.
   modified:
     libcore/as_object.cpp
     libcore/as_value.cpp
     libcore/asobj/Date_as.cpp
     libcore/asobj/Object.cpp
     libcore/vm/ASHandlers.cpp
     testsuite/swfdec/PASSING
   ------------------------------------------------------------
   revno: 10538.1.11
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 15:37:36 +0100
   message:
     Split long lines.
   modified:
     libcore/vm/ASHandlers.cpp
   ------------------------------------------------------------
   revno: 10538.1.12
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 16:17:59 +0100
   message:
     Pass a const std::string& to add_empty_movieclip().
   modified:
     libcore/MovieClip.cpp
     libcore/MovieClip.h
   ------------------------------------------------------------
   revno: 10538.1.13
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 17:00:41 +0100
   message:
     Correct Error implementation. Passes in actionscript.all.
   modified:
     libcore/asobj/Error_as.cpp
     testsuite/actionscript.all/Error.as
   ------------------------------------------------------------
   revno: 10538.1.14
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 17:41:54 +0100
   message:
     Correct prop flags for "extends". SWF5 still fails, probably because of
     prop flags when looking up constructor and __proto__.
   modified:
     libcore/as_function.cpp
     testsuite/swfdec/PASSING
   ------------------------------------------------------------
   revno: 10538.1.15
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 22:12:01 +0100
   message:
     Modify sed script so it doesn't drop half the lines from
     function-apply-?.out.swf.
   modified:
     testsuite/swfdec/swfdec_gnash_tester
   ------------------------------------------------------------
   revno: 10538.1.16
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 22:13:27 +0100
   message:
     function-apply-5.swf passes now the whole trace is compared.
   modified:
     testsuite/swfdec/PASSING
   ------------------------------------------------------------
   revno: 10538.1.17
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Mon 2009-01-12 22:34:39 +0100
   message:
     Assign correct "this" in function apply() calls undefined or non-object
     first argument.

     The only remaining failure in function-apply is the fact that arrays can't
     be faked in Gnash.
   modified:
     libcore/as_function.cpp
   ------------------------------------------------------------
   revno: 10538.1.18
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 07:55:23 +0100
   message:
     Indentation.
   modified:
     libcore/as_environment.cpp
   ------------------------------------------------------------
   revno: 10538.1.19
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 08:05:59 +0100
   message:
     Line breaks.
   modified:
     libcore/movie_root.cpp
   ------------------------------------------------------------
   revno: 10538.1.20
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 08:51:21 +0100
   message:
     Register LoadVars.decode as an ASnative, move to LoadableObject, and drop
     type checking. Passes in swfdec testsuite.
   modified:
     libcore/asobj/LoadVars_as.cpp
     libcore/asobj/LoadVars_as.h
     libcore/asobj/LoadableObject.cpp
     testsuite/swfdec/PASSING
   ------------------------------------------------------------
   revno: 10538.1.21
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 09:22:29 +0100
   message:
     Cosmetic change.
   modified:
     libcore/asobj/String_as.cpp
   ------------------------------------------------------------
   revno: 10538.1.22
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 12:05:41 +0100
   message:
     Clean ups.
   modified:
     libcore/as_object.cpp
     libcore/asobj/Global.cpp
   ------------------------------------------------------------
   revno: 10538.1.23
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 13:09:21 +0100
   message:
     Break long lines, especially long comments appended to lines of code,
     which are annoying and horrible.
   modified:
     libcore/asobj/Array_as.cpp
     libcore/asobj/NetStream_as.cpp
   ------------------------------------------------------------
   revno: 10538.1.24
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 13:25:30 +0100
   message:
     Always start the NetStream advance timer, so that status notifications
     are always sent. Pass in swfdec testsuite.
   modified:
     libcore/asobj/NetStream_as.cpp
   ------------------------------------------------------------
   revno: 10538.1.25
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 13:56:25 +0100
   message:
     Add pass in swfdec.
   modified:
     testsuite/swfdec/PASSING
   ------------------------------------------------------------
   revno: 10538.1.26
   committer: Benjamin Wolsey <address@hidden>
   branch nick: work
   timestamp: Tue 2009-01-13 14:11:42 +0100
   message:
     Finish documentation.
   modified:
     libcore/as_value.h





reply via email to

[Prev in Thread] Current Thread [Next in Thread]