[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gluster-devel] glusterfs bug? (was: Re: "found conflict" warning)

From: Emmanuel Dreyfus
Subject: [Gluster-devel] glusterfs bug? (was: Re: "found conflict" warning)
Date: Thu, 30 Sep 2010 07:58:15 +0000
User-agent: Mutt/1.5.20 (2009-06-14)

On Tue, Sep 28, 2010 at 03:07:44PM +0000, Emmanuel Dreyfus wrote:
> Still working on glusterfs for NetBSD. I have this message while
> I attemps to build something in the glusterfs filesystem. What does
> it means?

I wonder if this could be a glusterfs bug:
I mount /mnt from glusterfs, run vi /mnt/a and I kill -SEGV glusterfsd on the
client while /mnt/a is open.

I restart glusterfsd on the client, and then:
rm /mnt/a
=> Runs fine

touch /mnt/a
=> [2010-09-30 09:51:47] W [fuse-bridge.c:1679:fuse_create_cbk] glusterfs-fuse: 
create(/a) inode (ptr=0xbb90f2c0, ino=23, gen=2) found conflict 
(ptr=0xbb90f260, ino=23, gen=90657)

ls -l /mnt/a
ls: /mnt/a: No such file or directory
=> [2010-09-30 09:51:55] W [fuse-bridge.c:725:fuse_attr_cbk] glusterfs-fuse: 
12: STAT() /a => -1 (No such file or directory)

ls /mnt|grep a
=> readdir see the file but getattr does not, because it used the ino for the 
removed file, which it obtained by lookup.

Is that a bug in glusterfs or in NetBSD FUSE emulation? Any hint welcome. 
I am still running 3.0.5, this may be part of the problem.

Emmanuel Dreyfus

reply via email to

[Prev in Thread] Current Thread [Next in Thread]