gcmd-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gcmd-dev] gconf settings related segfault in debian testing


From: Michael
Subject: [gcmd-dev] gconf settings related segfault in debian testing
Date: Wed, 20 Aug 2014 03:34:30 +0200

I did some updates, which fiddled with some gnome libraries too, and then gcmd 
segfaulted with 

(process:12316): GLib-GObject-WARNING **: Attempt to add property 
GnomeProgram::sm-connect after class was initialised

(process:12316): GLib-GObject-WARNING **: Attempt to add property 
GnomeProgram::show-crash-dialog after class was initialised

(process:12316): GLib-GObject-WARNING **: Attempt to add property 
GnomeProgram::display after class was initialised

(process:12316): GLib-GObject-WARNING **: Attempt to add property 
GnomeProgram::default-icon after class was initialised

and after that, lots of these lines (apparently referring to default icons)

** (gnome-commander:12316): WARNING **: Couldn't load installed file type 
pixmap, trying to load ../pixmaps/gnome_cmd_arrow_up.xpm instead

** (gnome-commander:12316): WARNING **: Can't find the pixmap anywhere. Make 
sure you have installed the program or is executing gnome-commander from the 
gnome-commander-1.4/src directory

The only other oddball was claws-mail where the icon theme configurator stopped 
working. Any other Gnome app seemed ok.

Of course, all gcmd dependencies were met, green light by package resolver.

After checking around rather casually, i stumbled over 
'gconf-gsettings-backend' (then not installed) which i then installed, and 
voila┬┤ anything works fine again.

At that time, i've missed to set up the recommendet environment export 
GGSETTINGS_BACKEND=gconf  for my X desktop shell though ;) it still worked.

Then i discovered there was a package 'dconf-gsettings-backend' installed 
(automaticly, to satisfy dependencies). I could deinstall it w/o problems.










reply via email to

[Prev in Thread] Current Thread [Next in Thread]