[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gcl-devel] gclcvs_2.7.0-11

From: Michael Koehne
Subject: Re: [Gcl-devel] gclcvs_2.7.0-11
Date: Sat, 18 Oct 2003 16:11:48 +0200
User-agent: Mutt/1.3.28i

Moin Camm Maguire,

> > Greetings!  Well, gclcvs is not yet in sarge, but is in sid, so if you
> > add the stock unstable source tree to your apt.conf, you can just
> > 
> > apt-get -q -b source gclcvs
>   this wont work out of the box on Woody, as :
>       dpkg-checkbuilddeps: Unmet build dependencies: debhelper ( >= 4.1.0 ), 
> tk8.4-dev
>   so I'm now trying a :
>       dpkg-buildpackage -d -b -uc 2>&1 |
>           tee dpkg-buildpackage.tee
>   its still compiling (hours on a P250 ;) but I so far its looking well.

  i've installed the new debian package today, and took a look at
  /usr/bin/gclcvs first, when I saw 3 problems :

export C_INCLUDE_PATH=/fix/s/camm//usr/lib/gcl-2.7.0/h:$C_INCLUDE_PATH

  1: you want /bin/sh not /bin/bash, but you are using a bash only
     way to change and export in same line. This will produce problems
     where shell is not bash, like Solaris or AIX.
  2: the /fix/s/camm/ went into the /usr/lib/gcl-2.7.0/h C_INCLUDE_PATH.

  should read :


  I next tried to compile my XgclGL with this debian binary. I needed
  to patch my ./configure.in to give gclcvs preference over gcl.

>RESULT: compile-file sysinit.lsp failed.
cc -o raw_XgclGL xlib-bindings-c.o misc-bindings-c.o xlib-bindings-l.o 
misc-bindings-l.o elf-loader-l.o sysinit.o -L. -L/usr/lib/gcl-2.7.0/unixport 
-L/usr/X11R6/lib -lX11 -lXmu -lXt -lXext -lXaw -lGL -lGLU -u __gmpn_toom3_mul_n 
-lgcl -lm  -lgmp /usr/lib/libbfd.a /usr/lib/libiberty.a -lreadline -lncurses 
-lc -lgclp
sysinit.o: In function `user_init':
sysinit.o(.text+0x11): undefined reference to `init_or_load1'
sysinit.o(.text+0x26): undefined reference to `init_or_load1'
sysinit.o(.text+0x3b): undefined reference to `init_or_load1'
collect2: ld returned 1 exit status
make: *** [raw_XgclGL] Error 1

  any idea, what happend to init_or_load1 ?

  3: the new libgcl.a contains a gcl_init_or_load1 instead. Changing my
     sysinit.lsp worked, but this rename will break many sources !

Bye Michael
mailto:address@hidden             UNA:+.? 'CED+2+:::Linux:2.4.21'UNZ+1'
http://www.xml-edifact.org/           CETERUM CENSEO WINDOWS ESSE DELENDAM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]