gap-dev-discuss
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gap-dev-discuss] RSSKit/0.4 silent ABI break


From: Yavor Doganov
Subject: Re: [Gap-dev-discuss] RSSKit/0.4 silent ABI break
Date: Thu, 17 Jul 2014 13:10:10 +0300
User-agent: Wanderlust/2.15.9 (Almost Unreal) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 Emacs/23.4 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

Riccardo Mottola wrote:
> Yavor Doganov wrote:
> > This won't work as you expect with GNUstep Make -- 1.0 and 1.1 will
> > yield different SONAMEs.  Only the SUBMINOR version is not encoded in
> > the SONAME.  1 will be enough, but now it is not necessary to do it as
> > 0.4.0 has been released already and I guess the next release will be
> > binary compatible with 0.4.0, so that would classify as gratuitous
> > soname bump...
> >
> So essentially, you propose to do "nothing" ?

Basically, yes.  As there has been a public release changing the
interface version now will have no effect and will only be a hassle if
the next release is binary-compatible with 0.4.0 (the version is 0.4
BTW, the tarball too).
 
> I would still insert INTERFACE_VERSION = 0 though, so at least, it is 
> explicit and it helps remember us to bump it in the future.

Yes, I think this is a good practice and would serve as a reminder,
especially if it is near VERSION/PACKAGE_NAME.  You bump the version
for a new release and think about whether it is necessary to bump the
INTERFACE_VERSION.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]