[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [fluid-dev] Re: MIDI Standard Specs

From: S. Christian Collins
Subject: Re: [fluid-dev] Re: MIDI Standard Specs
Date: Wed, 08 Jul 2009 11:53:36 -0500
User-agent: Thunderbird (X11/20090608)

SoundFont synths that I have used over the years (such as the EMU10K1 synths) seem to put the default reverb at 0.  Personally, I think this is preferred.  I think reverb (like chorus) is one of those settings that should be left at 0 unless the musician specifically wants to add it to a channel.

What do you guys think?

David Henningsson wrote:
address@hidden skrev:
Quoting David Henningsson <address@hidden>:
Any objections to these (and similar) changes to make FluidSynth more in
line with the midi specifications?
I think using 100 for the volume parameter is a good idea.  As far as
the program number being that of the channel number by default, I think
that was for convenience of live playing, to be able to simply use
different instruments by switching channels.  I don't see it as that
convenient though and it would probably be good to just use the first
program number for all channels, especially if that is part of the MIDI
standard.  So feel free to make those changes :)

That change is now committed. Also this means that the standard reverb
level is 40 instead of 0. However, I was unable to notice that it made
any difference compared to what it was before, so I'm a little bit
puzzled over that - do you notice any difference, or did I miss

// David

fluid-dev mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]