[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: [Fab-user] Cant start tomcat with Fabric

From: PELLATT Robin
Subject: RE: [Fab-user] Cant start tomcat with Fabric
Date: Tue, 22 Mar 2011 16:44:25 +0100

I had the same problem. I think it’s something to do with the user environment that is set up when you login, which is somehow different when you login with SSH, but I never pinned it down exactly.  The only way I got this to work was to use the ‘root’ user in my fabric scripts instead of sudo.





-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Charlie White
22 March 2011 16:38
Subject: [Fab-user] Cant start tomcat with Fabric


Hello All,


   I'm looking for help with starting tomcat from Fabric. I've tried on a couple of different machines and none work. Oddly, stopping Tomcat works fine.


Here are my fabric functions:


def start_tomcat():

            sudo("/etc/init.d/tomcat-8080 start")


def stop_tomcat():

            sudo("/etc/init.d/tomcat-8080 stop")


On both shutdown and startup, I see the correct output. So from all appearances the start command was run on the remote server, and the expected output was seen, below:


[blueman.cashstar.lan] Executing task 'start_tomcat'

[blueman.cashstar.lan] sudo: /etc/init.d/tomcat-8080 start

[blueman.cashstar.lan] Login password: 

[blueman.cashstar.lan] out: Starting Tomcat 8080.

[blueman.cashstar.lan] out: Using CATALINA_BASE:   /usr/local/tomcat-8080

[blueman.cashstar.lan] out: Using CATALINA_HOME:   /usr/local/tomcat-8080

[blueman.cashstar.lan] out: Using CATALINA_TMPDIR: /usr/local/tomcat-8080/temp

[blueman.cashstar.lan] out: Using JRE_HOME:        /usr

[blueman.cashstar.lan] out: Using CLASSPATH:       /usr/local/tomcat-8080/bin/bootstrap.jar

[blueman.cashstar.lan] out: 



However, Tomcat is not starting, and Catalina.out shows no record of an attempted startup. I've also tried using other startup scripts like "catalina.sh start" and startup.sh, both of which have not worked.


Anyone have any ideas?


thanks a lot,

  Charlie White

IMPORTANT: This message is intended exclusively for information purposes. It cannot be considered as an official OHIM communication concerning procedures laid down in the Community Trade Mark Regulations and Designs Regulations. It is therefore not legally binding on the OHIM for the purpose of those procedures.
The information contained in this message and attachments is intended solely for the attention and use of the named addressee and may be confidential. If you are not the intended recipient, you are reminded that the information remains the property of the sender. You must not use, disclose, distribute, copy, print or rely on this e-mail. If you have received this message in error, please contact the sender immediately and irrevocably delete or destroy this message and any copies.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]