[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Enigma-devel] Enigma 1.10 - Mac OSX compilation

From: Sidney Markowitz
Subject: Re: [Enigma-devel] Enigma 1.10 - Mac OSX compilation
Date: Mon, 09 Mar 2009 03:10:06 +1300
User-agent: Thunderbird (Macintosh/20081209)

I finally worked through the problems with getting a MacOS X build.

I had a huge red herring when I could not get through the ./autogen.sh
step of the build because of errors in the perl module IO.pm

IO object version 1.22 does not match bootstrap parameter 1.23

I'm documenting it here because a search for the error message turned up
many queries without helpful results.

Once I got that fixed I was able to find the problem with the build I
uploaded. I'll upload a patch and a new build soon.


IO object version 1.22 does not match bootstrap parameter 1.23

This error was caused by Apple's security update 2009-001 when all three
of the following are true:

    * you are using Mac OS X 10.5 (Leopard)
    * and are using Perl that comes with Mac OS X
    * and have upgraded several core modules with CPAN in the past

The security update included an old version 1.22 of part of the IO
module. You can't use CPAN to reinstall the newer version because CPAN
will not run with this bug.

The fix is to download IO-1.2301.tar.gz from CPAN at
http://search.cpan.org/dist/IO/ and install it by untarring it and then
in its directory do

  perl Makefile.PL
  sudo make install

And do the same thing with Scalar::Util
and Storable

reply via email to

[Prev in Thread] Current Thread [Next in Thread]