[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Duplicity-talk] Purging, purge-full, not working?

From: Karl Buckland
Subject: [Duplicity-talk] Purging, purge-full, not working?
Date: Fri, 22 Aug 2014 10:52:31 +0100


I've been using Duply for a few months to backup up a handful of servers to Amazon S3. So far it's been working brilliantly.

I'm running Debian Squeeze on all of them, which ships with Duply However I have also tried using the latest 1.8.0 in order to ensure that my issue hasn't already been fixed. I have the same issue with both versions (and the equivalent commands for each).

Either I'm not using the purge commands properly, or it's not working.

I currently have Duply set up to do a full backup once a month, with incrementals every day, with these settings:

When I run the 'status' command, I can see:
Full backups: April 27, June 18, Jul 19, Aug 19
Incrementals: June 18 onwards
This is correct, as I originally ran a full backup and then left it for a little while before getting it to run regularly.

However, when I issue the 'purge' command, it lists out all files, full and incremental up to August 17th. I get this even if I issue the purge command as 'purge 3M' or 'purge 90D' or anything similar. It ignores my commands and appears to be ignoring the config file too?

I see the same issues with the purgeFull 3 and purgeIncr 3 commands. They ignore the config file and the arguments passed to them and they list everything up until the last week or so.

Have I misunderstood the commands and config file, or is there a legitimate issue?

Thanks in advance for any assistance.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]