[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] directory names with spaces (an old chestnut?)

From: edgar . soldin
Subject: Re: [Duplicity-talk] directory names with spaces (an old chestnut?)
Date: Mon, 18 Jun 2012 10:32:11 +0200
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120614 Thunderbird/13.0.1

On 18.06.2012 00:29, Adam Gold wrote:
> On 17 Jun 2012, at 23:22, Scott Hannahs wrote:
>> On Jun 17, 2012, at 6:08 PM, Adam Gold wrote:
>>> I know this subject has been discussed before 
>>> (http://lists.gnu.org/archive/html/duplicity-talk/2010-07/msg00017.html) 
>>> but I'd like to get the 'up-to-date' answer, as it were, which I haven't 
>>> been able to find - sorry if I missed it.  I can't restore directories 
>>> which have spaces in the names, whether I use quotes (single or double) or 
>>> an escape character.  I get a message which says something along the lines 
>>> of "Expected 2 args, got 3".  I'm using duply as a wrapper so an example 
>>> command is: duply fileset fetch 'fileset/files/this directory' 
>>> '/home/restore' .  I've also tried duplicity 
>>> 'file:///archive_location/fileset/files/this directory' '/home/restore'.
>>> Can this actually be done or should I simply eliminate spaces from the 
>>> names of directories before I backup?  Obviously I won't be naming any new 
>>> directories with spaces in the name.
>> Try Single quotes and an escape character.  This generally works for passing 
>> paths to a remote process.
>> 'File\ Name\ With\ Spaces'
>> (I haven't tried this with duplicity, but it works for rsync and ssh)
>> -Scott
> Thank you, thank you, thank you !

you probably stumbled over a bug in duply that was reintroduced some versions 

generally wrapping paths containing spaces in single or double quotes should be 
enough.. only if the path is relayed incorrectly within applications (prominent 
example being rsync or buggy duply) you might need the workaround to escape the 
space or other special char via backslash. sometimes you even have to escape 
the backslash so it survives interpretation in first application you give it to 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]