[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] directory names with spaces (an old chestnut?)

From: Scott Hannahs
Subject: Re: [Duplicity-talk] directory names with spaces (an old chestnut?)
Date: Sun, 17 Jun 2012 18:22:59 -0400

On Jun 17, 2012, at 6:08 PM, Adam Gold wrote:

> I know this subject has been discussed before 
> (http://lists.gnu.org/archive/html/duplicity-talk/2010-07/msg00017.html) but 
> I'd like to get the 'up-to-date' answer, as it were, which I haven't been 
> able to find - sorry if I missed it.  I can't restore directories which have 
> spaces in the names, whether I use quotes (single or double) or an escape 
> character.  I get a message which says something along the lines of "Expected 
> 2 args, got 3".  I'm using duply as a wrapper so an example command is: duply 
> fileset fetch 'fileset/files/this directory' '/home/restore' .  I've also 
> tried duplicity 'file:///archive_location/fileset/files/this directory' 
> '/home/restore'.
> Can this actually be done or should I simply eliminate spaces from the names 
> of directories before I backup?  Obviously I won't be naming any new 
> directories with spaces in the name.

Try Single quotes and an escape character.  This generally works for passing 
paths to a remote process.

'File\ Name\ With\ Spaces'

(I haven't tried this with duplicity, but it works for rsync and ssh)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]