[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Duplicity-talk] remote_maifest problem

From: Ben Escoto
Subject: Re: [Duplicity-talk] remote_maifest problem
Date: Wed, 3 May 2006 20:18:03 -0500

>>>>> Michael Johnson <address@hidden>
>>>>> wrote the following on Mon, 1 May 2006 08:20:08 -0400
> >>>>>> Michael Johnson <address@hidden>
> >>>>>> wrote the following on Sun, 30 Apr 2006 23:35:31 -0400
> >>
> >> UnboundLocalError: local variable 'local_manifest' referenced before
> >> assignment
> >>
> >>> If you are using the --archive-dir option, make sure that non- 
> >>> root can
> >>> read the files in that directory.
> >>
> >> I don't think I am doing this.  I don't specify it in the command, so
> >> unless it's a default setting, it's not done.
> >
> > It looks like this is a duplicity bug, but it may be triggered because
> > there is some corrupted or partial backup set in the repository.  Do
> > you get this error if you backup to a new (empty) directory?
> Yes...I created a completely new backup set and empty directory.   
> When I ran it on this machine, it failed with the same error.  When I  
> ran it on the other machine where duplicity is working, it worked.

There is a typo that this patch fixes:


However, with this patch rdiff-backup will probably still not work in
that situation.  (It will just exit with a more informative error
message instead of a traceback.)

I'm not sure what is causing the problem.  It seems though that
rdiff-backup is finding some backup set in the repository, but cannot
load the manifest file from that backup set.  You said you get this
when backing up to an empty directory, so I don't know why it thinks
there are existing backup chains.

Ben Escoto

Attachment: pgph0uc0CrsjG.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]