[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss-gnuradio] Cygwin Python Import Error

From: Brian Padalino
Subject: [Discuss-gnuradio] Cygwin Python Import Error
Date: Sat, 10 Feb 2007 16:18:08 -0500

I had an old version of GNURadio installed on my cygwin setup, but
decided to get the current development version in the svn repository.

After checking it out, bootstrapping, configuring and starting a make
- I had an error where the linker complained about omnithread being
made into a static library and not shared followed by a whole bunch of
missing omnithread declarations.

I got around this by doing --enable-shared=omnithread at configure,
and it went past that point.  Once the build was successful, I went
and did an make install and tried to run python and import gr.  Here
are the results:

$ python
Python 2.4.3 (#1, May 18 2006, 07:40:45)
[GCC 3.3.3 (cygwin special)] on cygwin
Type "help", "copyright", "credits" or "license" for more information.
from gnuradio import gr
Traceback (most recent call last):
 File "<stdin>", line 1, in ?
 File "/usr/local/lib/python2.4/site-packages/gnuradio/gr/__init__.py",
line 27, in ?
   from gnuradio_swig_python import *
line 23, in ?
   from gnuradio_swig_py_runtime import *
line 6, in ?
   import _gnuradio_swig_py_runtime
ImportError: No module named _gnuradio_swig_py_runtime

I have 2 files in /usr/local/lib/python2.4/site-packages/gnuradio/gr
with the name _gnuradio_swig_py_runtime - one an ar archive and the
other a libtool library file.

After this error, I went and tried make check and I fail with the error:

make  check-TESTS
make[4]: Entering directory `/tmp/gnuradio/gnuradio-core/src/tests'
 14645 [main] test_all 620 _cygtls::handle_exceptions: Error while
dumping state (probably corrupted stack)
/bin/sh: line 4:   620 Segmentation fault      (core dumped) ${dir}$tst
FAIL: test_all.exe
1 of 1 tests failed
make[4]: *** [check-TESTS] Error 1
make[4]: Leaving directory `/tmp/gnuradio/gnuradio-core/src/tests'
make[3]: *** [check-am] Error 2
make[3]: Leaving directory `/tmp/gnuradio/gnuradio-core/src/tests'
make[2]: *** [check-recursive] Error 1
make[2]: Leaving directory `/tmp/gnuradio/gnuradio-core/src'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/tmp/gnuradio/gnuradio-core'
make: *** [check-recursive] Error 1

I really have no idea what's going on, so any help would be appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]