[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

build failure on cross build

From: Christer Solskogen
Subject: build failure on cross build
Date: Wed, 28 Mar 2012 20:22:54 +0000 (UTC)
User-agent: Loom/3.14 (


I've created my "own" cross compiler for powerpc (gcc, binutils and eglibc) and 
I'm having trouble cross compiling coreutils with that compiler. I do not have 
trouble compiling both binutils, eglibc and bash with the same compiler but I 
that does not mean that the cross compiler works perfectly. 
The build error I get is this, and I have not found a single place on google 
this error is mentioned:

make[3]: Entering directory `/home/solskogen/obj/coreutils.ppc/lib'
  CC       set-mode-acl.o
  CC       copy-acl.o
  CC       file-has-acl.o
  CC       allocator.o
  CC       areadlink.o
  CC       areadlink-with-size.o
  CC       areadlinkat.o
  CC       argmatch.o
In file included from /home/solskogen/src/coreutils/lib/argmatch.c:28:0:
./stdio.h:1029:1: error: 'gets' undeclared here (not in a function)
make[3]: *** [argmatch.o] Error 1
make[3]: Leaving directory `/home/solskogen/obj/coreutils.ppc/lib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/solskogen/obj/coreutils.ppc/lib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/solskogen/obj/coreutils.ppc'
make: *** [all] Error 2

I got the same error on both coreutils-8.15 and coreutils-8.16. I've not tried
any other versions yet.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]