bug-parted
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

partition types


From: Matt_Domsch
Subject: partition types
Date: Tue, 16 Jan 2001 18:08:55 -0600

> > Reflecting on partition types, we need the idea of contents:
> > part->type == {PRIMARY, LOGICAL, EXTENDED, FREESPACE, METADATA}
> > part->contents = {FILESYSTEM, SWAP (should be in FILESYSTEM, but it's
not),
> > RAID, LVM, special)
> 
> OK, you've convinced me :-)

Yea! 

> 
> But this isn't going in 1.4.x, because it's too significant a change
> for other programs (like Conectiva's Modular Installer) to update, to
> keep compatible.

Sure.

> 
> > part->fs_type = {any of the file systems}
> > part->flags = {LBA, hidden, boot}
> > 
> > Conceptually, we're trying to describe the contents of a 
> partition, which
> > can be one listed above.  Because they're all mutually 
> exclusive, it makes
> > sense for me to assign my PartitionTypeGuid to one of those values.
> 
> Yes.
> 
> > Flags
> > don't show the mutual exclusion properly (though I've 
> implemented them in
> > terms of set/get flags functions, if that's fixed I'll 
> change my code).
> > Flags for LBA, hidden, boot are OK.
> 
> Flags aren't mutually exclusive.  Eg: you can (and usually) have an
> LBA boot partition for Windows.

Right, I was unclear.

>  
> > Therefore, I can have the following types:
> > PARTITION_BASIC_DATA_GUID = partition will contain any 
> normal file system
> 
> s/BASIC_DATA/FILE_SYSTEM/ ?

Yep, but my GUID is named "BASIC_DATA" because that's what the spec calls
for.
In parted, calling it PED_PARTITION_CONTENTS_FILE_SYSTEM (or whatever) is
good.


> > PARTITION_LINUX_SWAP_GUID = Linux swap (needed because no 
> present installer
> > has swapfs-detection code, but they typically test for 
> system==0x82, this is
> > the equivalent)
> > PARTITION_LINUX_RAID_GUID = partition will contain a RAID 
> superblock - raid
> > flag sets/clears this
> > PARTITION_LINUX_LVM_GUID  = partition will contain a LVM 
> superblock  - lvm
> > flag sets/clears this
> > PARTITION_SYSTEM_GUID     = partition will contain 
> FAT12/16/32 FS - required
> > for IA-64 - boot flag sets/clears this
> 
> Why have "LINUX" in the name?  Is there anything special about this?
> Why won't the BSD people do the same as us, for example?

The superblocks are different across different OSs, but you're right, I can
drop "LINUX".
(Since I put "LINUX" in the RAID_GUID there, and that code is already in the
IA-64 kernel
tree, I don't want to change that one now.  After ia-64 stabilizes, I'd
consider this).

> > Last thing I need to add is label support.  I can have 
> unicode labels.  Have
> > you thought about that?
> 
> libparted already supports labels for partitions.  Are you talking
> about labels for the disk?  We can do that.

Naah, for partitions.  I've got unicode, you've got char *.  I added code to
convert, assuming only the bottom 8 bits are important.  Ugly, but
functional for now.  A label command that took unicode would be cool.

Thanks,
Matt

 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]