[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problems building gnustep-startup on osx

From: Adam Fedor
Subject: Re: problems building gnustep-startup on osx
Date: Fri, 1 Jul 2005 21:16:45 -0400

On Jul 1, 2005, at 5:43 PM, Jon Brisbin wrote:

I just downloaded the latest gnustep-startup and tried compiling it on my powerbook (using darwinports' gcc4)

Everything compiles fine, but, as with my problems with GNUstep on Win32, it crapped out when it tried to link. I can probably get away with just using XCode and being careful to not use anything Cocoa-specific. But that won't let me use the GNUstep XML stuff, which I desperately need to test porting an application from Java to Objective-C. I'd like to be able to work on it on my PowerBook, but if I can't, I might not be able to do this project at all (unless I put PPC linux on here too, but I'd rather not do that.) It's kind of part work-related and part not ;-)

Any help or ideas would be greatly appreciated! :-)

Jon Brisbin

 Linking tool autogsdoc ...
/opt/local/bin/odld: Undefined symbols:

Maybe you could try to compile the base library individually like this:

make messages=yes

and see if it is linking in the libobjc library and perhaps from where.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]