[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PSPP-BUG: I "have discovered a bug in PSPP."

From: John Darrington
Subject: Re: PSPP-BUG: I "have discovered a bug in PSPP."
Date: Mon, 5 Dec 2005 08:55:32 +0800
User-agent: Mutt/1.5.9i

On Sat, Dec 03, 2005 at 02:22:32PM +0100, Christian Herzberg wrote:
     Dear PSPP-programmer,
     I tried out PSPP with some SPSS-Syntax from an survey, we made for a 
     university. I'm not into statistics or SPSS really. I tried out for 
     who should get rid of SPSS.
     When I  tried '$ pspp -o html myfile.syn', I get this MESSAGE back:
     You have discovered a bug in PSPP.
       Please report this, by sending an email to address@hidden,
     explaining what you were doing when this happened, and including
     a sample of your input file which caused it.
     Also, please copy the following lines into your bug report:
     bare_version:        0.4.0
     version:             GNU pspp 0.4.0
     stat_version:        GNU pspp 0.4.0  (Mon Sep 26 19:45:23 EDT 2005).
     host_system:         i486-pc-linux-gnu
     build_system:        i486-pc-linux-gnu
     default_config_path: ~/.pspp:/etc/pspp
     include_path:        ./:~/.pspp/include:/usr/share/pspp
     locale_dir:          /usr/share/locale
     compiler version:    4.0.1 (Debian 4.0.1-2)
     Diagnosis: Segmentation Violation
     I shortend the syntax to made out where it came from.
     4 parts are still there now (refering to the syntax).
     It became clear, that when I comment out one part, the MESSAGE is gone.
     May be it's an error in the '*.sav'-data-file, but I can't reveal it now.
     Thanks for PSPP and for the possibility to choose.
     Christian Herzberg

     * when running pspp, the next line was commented out and points to the 
     *GET FILE=''

If you can provide an example of a *.sav file which causes this
problem, then perhaps somebody can look at it.  Otherwise it's a bit
difficult to do anything about it.

     PS: Another topic: When I tried the option '-o list-ps'  I get:
     installation error: PostScript driver: Cannot find encoding `text.enc' for
             PostScript font `<<fallback>>'.
     I'm a PSPP beginner, an the manual overwhelmed me. So if there's
     a short hint,       I would be glad to here/read it.

This question is perhaps best asked on the address@hidden list.
However, on Debian, I believe you need to do:

 export GROFF_FONT_PATH=/usr/share/groff/current/font/



PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See http://pgp.mit.edu or any PGP keyserver for public key.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]