bug-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#28597: 26.0.60; [Security] Configure should use --without-pop by def


From: Robert Pluim
Subject: bug#28597: 26.0.60; [Security] Configure should use --without-pop by default
Date: Tue, 03 Oct 2017 10:09:15 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.60 (gnu/linux)

Paul Eggert <address@hidden> writes:

> Thanks for working on this. However, Eli asked for --with-pop to
> remain the default on native MS-Windows. Also, I found the newly-added
> warnings confusing (though admittedly everything is confusing here
> :-).

You're right, I thought he was talking only about the Mailutils
recommendation, but I misread.

> How about the attached patch instead? It does not change the
> configure-time warnings. It merely changes the default, so that
> --without-pop is now the default on platforms other than native
> MS-Windows.

Eli wanted to avoid silently changing the default, which is why I
worked on creating confusing warnings :-)

I'm not wedded to the form, but I think configure should output
*something* to warn people about the change in behaviour.  Or we go
full radical and disable building our own mailutils on non MS-Windows,
thus simplifying this mess greatly (we'd have to warn a bit more
loudly if GNU Mailutils aren't installed, though)

Robert





reply via email to

[Prev in Thread] Current Thread [Next in Thread]