bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #45940] CVS cannot connect to remote repo on MSWindows7


From: Vincent Belaïche
Subject: [bug #45940] CVS cannot connect to remote repo on MSWindows7
Date: Sat, 26 Sep 2015 20:00:11 +0000
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko

Follow-up Comment #3, bug #45940 (project cvs):

 Hello,

I think that I have found what was going wrong. In fact I had two problems at
the same time, which made sorthing this out a bit more chalenging.


= My 1st problem =

On my MSW-XP machine, the PuTTY ssh program (aka plink) was there:


C:Program FilesPuTTYplink.exe


and I had configured the envvars like this:


 $ @echo CVS_SSH = %CVS_SSH%, CVS_RSH = %CVS_RSH%.
-| CVS_SSH = C:Program FilesPuTTYplink.exe, CVS_RSH = C:Program
FilesPuTTYplink.exe.


and everything was fine, but on my MSW-7 machine, the PuTTY program was
installed there:


C:Program Files (x86)PuTTYplink.exe


and therefore I had accordingly configured the envvars like this:


 $ @echo CVS_SSH = %CVS_SSH%, CVS_RSH = %CVS_RSH%.
-| CVS_SSH = C:Program Files (x86)PuTTYplink.exe, CVS_RSH = C:Program Files
(x86)PuTTYplink.exe.


but that was a problem, as I got :


 $ cvs -z3 -d:pserver:address@hidden:/cvsroot/jpicedt
co -P jpicedt
-| cvs.exe [checkout aborted]: connect to
jpicedt.cvs.sourceforge.net(216.34.181.112):2401 failed: Connection timed out


Only the :perserver: protocol is affected by this problem (anonymous access).
The :ext: is fine (authenticated access).

Now this first problem was solved by replacing "Program Files (x86)" by the
equivalent short name, which is "PROGRA~2" in my case, you can know yours by
doing:


 $ dir /X C:
-|  Le volume dans le lecteur C n'a pas de nom.
-|  Le numéro de série du volume est AC5E-0292
-| 
-|  Répertoire de c:
-| 
-| 03/12/2013  22:34    <REP>                       Drivers
-| 26/09/2015  15:48    <REP>          PROGRA~1     Program Files
-| 26/09/2015  15:53    <REP>          PROGRA~2     Program Files (x86)
-| 01/07/2014  22:30    <REP>          PROGRA~4     Programmes
-| 26/03/2015  14:45    <REP>                       Users
-| 25/09/2015  10:59    <REP>                       Windows
-|                0 fichier(s)            0 octets
-|                6 Rép(s)  167 059 132 416 octets libres


So after doing this:


 $ @echo CVS_SSH = %CVS_SSH%, CVS_RSH = %CVS_RSH%.
-| CVS_SSH = C:PROGRA~2PuTTYplink.exe, CVS_RSH = C:PROGRA~2PuTTYplink.exe.


and  CVS works.

= My 2nd problem =

In fact it was not working in my case neither for authenticated access, nor
for anonymous access, because I had a second problem. As you can read on
Sourceforge CVS doc <https://sourceforge.net/p/forge/documentation/CVS/>,
sourcefore supports CVS up to CVS 1.11.x. However I was using CVS 1.12.13a,
here is what I get with CVS 1.12.13a correctly configures envvars CVS_RSH and
CVS_SSH:


 $ cvs -z3 -d:ext:address@hidden:/cvsroot/jpicedt co -P
jpicedt
-| cvs.exe [checkout aborted]: reading from server: No such file or directory

error-> Unable to write to standard output: Le canal de communication est sur
le point d'être fermé.
 $ cvs -z3 -d:pserver:address@hidden:/cvsroot/jpicedt
co -P jpicedt
-| cvs.exe [checkout aborted]: connect to
jpicedt.cvs.sourceforge.net(216.34.181.112):2401 failed: Connection timed out


If in addtion the envars are configured with "Program Files (x86)" instead of
"PROGRA~2", which was my initial situation on MSW-7, then I get the same
errors:


 $ cvs -z3 -d:ext:address@hidden:/cvsroot/jpicedt co -P
jpicedt
-| cvs.exe [checkout aborted]: reading from server: No such file or directory

error-> Unable to write to standard output: Le canal de communication est sur
le point d'être fermé.
 $ cvs -z3 -d:pserver:address@hidden:/cvsroot/jpicedt
co -P jpicedt
-| cvs.exe [checkout aborted]: connect to
jpicedt.cvs.sourceforge.net(216.34.181.112):2401 failed: Connection timed out





    _______________________________________________________

Reply to this item at:

  <http://savannah.nongnu.org/bugs/?45940>

_______________________________________________
  Message posté via/par Savannah
  http://savannah.nongnu.org/




reply via email to

[Prev in Thread] Current Thread [Next in Thread]