bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Issue with cvs and glibc 2.10.1


From: Quentin RAMEAU
Subject: Re: Issue with cvs and glibc 2.10.1
Date: Tue, 21 Jul 2009 22:00:10 +0200 (CET)

Well, I made a patch anyway that changes instances of 'getline' to 'getline_'.
I'm not sure if that is the best to do, but I give it in case you'd agree to do 
that.

2009/7/21 Quentin RAMEAU <address@hidden>
Hi,

I tried to build cvs 1.11.23, but I encountered an incompatibility with glibc 
2.10.1:

In file included from getline.c:25:
getline.h:15: error: conflicting types for 'getline'
/usr/include/stdio.h:651: error: previous declaration of 'getline' was here
getline.c:158: error: conflicting types for 'getline'
/usr/include/stdio.h:651: error: previous declaration of 'getline' was here

I am not skilled enough to make a patch, maybe glibc version should be tested 
before trying to include/build lib/getline ?

- quinq

Attachment: signature.asc
Description: OpenPGP digital signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]