bug-cvs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: compiling CVS on HP-UX


From: Jay
Subject: RE: compiling CVS on HP-UX
Date: Mon, 16 Mar 2009 10:08:12 +0000

11.11 is 11iv1.
There is indeed roughly 11iv2 == 11.22, 11i.v3 == 11.33.
Yes 11.11 is a bit old, from 2000 or 2001, but still has
been patched pretty recently, like in 2008.
 
I have installed a few patches and several of the patch descriptions mention 
flawed headers or libs, so maybe it is ok now.
 
I'm not blocked.
I have 11iv2 but haven't reinstalled yet.
 
 - Jay


----------------------------------------
> From: address@hidden
> To: address@hidden
> CC: address@hidden
> Subject: Re: compiling CVS on HP-UX
> Date: Mon, 16 Mar 2009 02:46:13 -0700
>
> Hi Jay,
>
> I do not have access to an HP/UX 11.11 box
>
> (This HP/UX is kind of an old OS isn't it? I think I have seen mentions
> of 11.31 and something called 11i by now...
>
> I am not very happy with the idea of putting this much OS-specific glop
> into src/server.c ... :-(
>
>
> # ifdef HAVE_GETSPNAM
> /*
> * On HP-UX 11.11, shadow.h and prot.h provide conflicting
> * declarations of getspnam when _INCLUDE__STDC__ is defined, so we
> * unset it here. XXX: Is there an __hpux11? Is this broken in newer
> * HP-UX 11.xx releases? When can we stop doing this hack?
> */
> # if defined(__hpux) && !defined(__hpux10) && defined(_INCLUDE__STDC__)
> # undef _INCLUDE__STDC__
> # endif
>
> # include 
>
> # endif
>
>
> -- Mark



reply via email to

[Prev in Thread] Current Thread [Next in Thread]